Support » Plugin: Absolutely Glamorous Custom Admin » Save button doesn't work

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author WAP Support


    Please take a look in the browser’s console. It is very possible that an error is logged there for some reason. Please post it back here. Thanks.

    Dear @argonius, This is the browser console log, It appears when I clicked on Save button.

    Uncaught ReferenceError: isSettingsImport is not defined           ag_script.js:49
    processData                                                        ag_script.js:49
    (anonymous function)                                              ag_script.js:40
    v.event.dispatch                                                     load-scripts.php:2
    o.handle.u                                                           load-scripts.php:2
    v.event.trigger                                                       load-scripts.php:2
    (anonymous function)                                               load-scripts.php:2
    v.extend.each                                                        load-scripts.php:2
    v.fn.v.each                                                           load-scripts.php:2
    v.fn.extend.trigger                                                   load-scripts.php:2
    v.fn.(anonymous function)                                           load-scripts.php:2
    savePluginSettings                                                   ag_script.js:36

    Here is a screen shot.


    Plugin Author WAP Support


    I think this is related to the first error which is thrown in tools.php 233
    Please try to navigate to this page in your browser directly and see if this error is visible in console again.

    You can try to view the source of the generated page: right click -> View Page Source, and try to find that line. Please post your results back here.


    Dear argonius,
    If I deactivate the AGCA plugin and browser wp-admin/tools.php there is no error in console. If I switch it on. There it is. The error.

    Line 232. (New line in console.)

    jQuery("#footer-upgrade").html('බලය ලැබුවේ WordPress මඟිනි. නිර්මාණය <a href="" title="Creation's inc."> Creation's inc.</a>');

    (If you see boxes, They are Sinhala characters.)

    Also error is showed on every page. (in console)


    Plugin Author WAP Support


    Thank you for the brief explanation. A single quote character is probably causing this error. Please find the line:

    jQuery("#footer-upgrade").html('<?php echo get_option('agca_footer_right'); ?>');

    in plugin.php and replace it with this line:

    jQuery("#footer-upgrade").html('<?php echo addslashes(get_option('agca_footer_right')); ?>');

    I think this should fix this problem. You can expect that this patch will be applied in next versions, so you don’t have to worry about it when you upgrade your AGCA plugin.


    Thanks argonius,

    I will try and let you know. Thanks for the quick reply.


    Thank you Argonius!

    The patch above works perfectly.


    Didn’t work for me ):

    I have this error:
    (from firebug)

    ReferenceError: isSettingsImport is not defined
    [Break On This Error] 	

    on (line 653)


    SyntaxError: unterminated string literal
    [Break On This Error] 	
    s las páginas", "undefined"],["Añadir nueva", "undefined"],["

    on (line 86, col 60) (am using WP in Spanish, but only the pot files translate it. Tried in English too, but still no go)


    ReferenceError: wpversion is not defined
    [Break On This Error] 	
    wp_ver: wpversion,

    on (line 868)

    any ideas? ):

    I did exactly this you mention. but nothing.
    Thanks in advance, 😀

    Plugin Author WAP Support



    I think this problem is related to quote characters in your custom admin menu buttons names. If this is the case, this problem will be fixed in next version. Please delete AGCA and all AGCA settings and files (confirmation button YES), and install fresh copy after that. Then, populate custom buttons one after another and choose save AGCA settings between each change. Find out after which change AGCA is broken.

    You could also send me a copy of your rendered page to email for debugging. The problem is most likely in JavaScript when settings this variable “textboxes”. So you could try to find this:

    var textboxes =[some json data]

    to check.


    Plugin Author WAP Support


    Please remove all data from current AGCA version, and try to install this new beta version It should hopefully contain fix for this issue.

    @argonius, I’m terribly sorry about the delay. There was heavy raining and thundering in Kandy (Sri Lanka) So I couldn’t able to reply to you. As you said, I’ve updated the plugin.php and it’s working now. Thanks very much Brother.

    Plugin Author WAP Support


    No problem at all. Thank you for your feedback. Patch for this issue is applied in new version Thanks!

    I am experiencing the same problem “save button does’nt work” with one of my website on a wordpress multisite with a version of AG custom admin. The console errors are : wpversion is not defined ag_script.js:881 and isSettingsImport is not defined ag_script.js:654.

    Reading above, i thought the problem was fixed in version ?

    My concern is to have to deactivate the plugin and reactivate it : I will have to configure the admin menu for all the website working well today.

    What should I do ?

    Thanks in advance

    Plugin Author WAP Support


    You have different error with the same effect. To resolve that error, please try clearing browser’s cache first. If that does not solve it, please update the plugin to new version. You don’t need to reinstall it.

    Hi Argonius,

    Thanks for your quick reply. Before asking for support, I already clean my browser’s cache and updated to the last version and I still exprerience the same trouble.

    Investigating, I found that I used a quote in the custom blog heading (Fil d’actu portail) and I wonder if this is not the trouble. I have in the console Uncaught SyntaxError: Unexpected identifier tools.php:124
    due to
    jQuery(“#wphead #site-heading”).after(‘<h1>Fil d’actu portail</h1>’);

    What is your analysis ?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Save button doesn't work’ is closed to new replies.