Support » Plugin: Migrate WordPress Website & Backups - Prime Mover » Runtime error when restoring

  • Resolved fergu5

    (@fergu5)


    I have been able to restore a database only package but I can’t restore a package with media or plugins and themes. Where a restore fails I get a Runtime error.
    The package with media, plugins and themes is around 370M for example.

    Is there perhaps a memory or timeout requirement I need to have in place for the processing of the package to complete?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Codexonics

    (@codexonics)

    Thank you for reporting this error to us. We also sent a reply to the bug report you’ve sent via Prime Mover contact form. Please check on it as well so you can send us the error log details.

    Basically, Prime Mover does not require high memory or timeout requirement since it will automatically adjust these parameters based on it’s environment. There are times on extreme cases that this can affect the process. This will shown on the error log report.

    However it would be worth trying to restore on a fresh WordPress installation by clearing database, uploads folder, plugins/themes to see if that helps:

    1. Start with a fresh WordPress installation, you can use WordPress Reset plugin to reset your database to a fresh installation
    2. Delete all files in your /wp-content/uploads/ if its not important since this will be entirely replaced with the migrated package files.
    3. Delete all plugins in /wp-content/plugins/ as they will be replaced with the plugin files from the package except Prime Mover plugin.
    4. Switch to default WordPress theme (2020 for example
    5. Now activate Prime Mover plugin only.
    6. Restore the package directly from WordPress admin since it’s faster and safer than using upload, please follow this tutorial.

    That’s it, please let me know if that works. If you can still see the runtime error; please reply to the bug report we’ve sent via the contact us form and provide the error log details to it. We will then check what’s causing it. Thanks 🙂

    Plugin Author Codexonics

    (@codexonics)

    As an update, we’ve identified the issue and sent you a hot-fix version of the Prime Mover plugin. Please do another restore by starting with a fresh WordPress installation. And then restore the package using the hot-fix version provided.

    Details of the procedure to restore your site was included in our bug report replies. We’ve tested the procedure using the provided package and it works now without any runtime errors. Please confirm in your end. Thanks! 🙂

    Plugin Author Codexonics

    (@codexonics)

    @fergu5 Prime Mover 1.2.1 is now released that includes the permanent fix for this issue. This is the fix that is tested to work at your site. I’m marking this ticket now as resolved. Thanks!

    • This reply was modified 2 years, 3 months ago by Codexonics.
    Thread Starter fergu5

    (@fergu5)

    Got the update this morning. Thanks again for you attention to my issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Runtime error when restoring’ is closed to new replies.