RSS problem

  • total newbie here – who is having real trouble getting my head around some of this
    I have trawled around for a couple of days trying to figure this out
    when I click on RSS 2.0 link and comments RSS 2.0 link i get an error
    “Not Found
    The requested URL /blog/feed/rss2/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. “
    if I try and access
    I can see it
    after searching the support forums I thought it might be the htaccess file – but I could be wrong because I am not sure about any of this stuff
    If I ftp to the site I can see a htaccess file in my public_html directory but not one in the ‘blog’ folder
    If I try to edit it through WordPress interface I get
    Editing .htaccess
    Oops, no such file exists! Double check the name and try again, merci.
    The Question is – do i have to create a htaccess file to solve this problem – if so how? Or am I going off in a wrong direction –
    I seem to have been mucking about with this blog for weeks (transfering from Typepad) any help out there would be most appreciated – as I say I am a newbie at this

Viewing 15 replies - 1 through 15 (of 24 total)
  • Thanks for the quick reply – I tried it but I still get the same error – would the output from the options | permalinks posted here help anyone?

    sorry to post again – the fact that I had the permalinks working – but not the RSS confuses me no end – and there wasn’t a htaccess file until I created one – so I am still scratching my head… have learnt heaps along the way though

    just tried it and now i have lost my permalinks …

    You have to then copy the new output into the htaccess file.

    I did – and thats when I lost the perma links and still the same error for rss –
    do you want to see the output here?
    I am poking around your blog…

    Nah, won’t help. If you put in the suggested structure, hit update and then copied the result into .htaccess and ftp’d it into your blog directory that should be it.

    yep I did that – but I will try again incase I did something dumb –

    I use:

    yes I just tried it again – with your structure – and it did not work –
    just to make sure we are not talking at cross purposes (as i am new to this stuff) I am looking at options \permalinks towards the bottom
    the /archives etc is in a box just above the update permalink structure button – I click that
    select all the text that is generated
    paste it inot the htaccess file and ftp it to my blog site
    am I doing right?

    yes “RewriteEngine On” and is in the blog directory
    I have had a lot of problems really – have to go now its knock off time in OZ – what is it over there? will check back in later on tonight and see if you have come up with some magic –
    I am wondering if I should just start over again … I have had alot of glitches over the past few weeks trying to set this up

    I have just put back the index.php in the permalink –
    just thought I would try it
    and permalinks and the RSS now working – so something kicked in but i don’t really know what – would love to know if anyone has any insights that I can understand!
    thanks Beel for your help something in all that cleaned up the error.

    I have had the same problem – rss link gave the 404 error as soon as I enabled permalinks using the ‘/index.php/’ structure for permalinks (i.e. no need for .htaccess file). Permalinks worked fine after that but then the rss link generated the 404 error. I disabled permalinks and the rss feed started to work again. Maybe I have to figure out the .htaccess approach to permalinks in order to get both permalinks and rss working

    did everything as supposed, but as soon as I upload .htaccess /(as Ascii)
    my server tells me:
    ‘ Forbidden
    You don’t have permission to access / on this server.’
    I use a standart LAMP -System.
    Blog-dir is root
    CAn you help?

    Moderator James Huff


    Have you contacted your hosting provider?

    I am using serveral .htaccess- Files. When I delete the .htaccess file with the lines from options /permalinks, everything is fine.
    Here my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php/archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/category/?(.*) /index.php?category_name=$1 [QSA]
    RewriteRule ^index.php/archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/author/?(.*) /index.php?author_name=$1 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1&withcomments=1 [QSA]

    Is there a conflict with my apache configuration? Or just a bug in those lines

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘RSS problem’ is closed to new replies.