Support » How-To and Troubleshooting » [Resolved] RSS Feed Problems

[Resolved] RSS Feed Problems

  • When I try to read my blog thru a RSS newsreader called NewsGator, it comes up with an error saying “The underlying connection was closed: The server committed an HTTP protocal violation.” It never did this until 2 days ago and now I can’t read my blog via my RSS reader, what’s wrong here?
    My blog is located at http://techblog.windowsatoz.com if that helps. Thanks.

Viewing 15 replies - 1 through 15 (of 36 total)
  • Might be an issue with NewsGator, perhaps? I just checked using RssReader (http://www.rssreader.com/) and it connected to the feed without any trouble at all….

    I’m having the same issue, but not just with NewsGator. I’ve tried SharpReader and Sauce Reader and its not just my blog, all wordpress blogs in my RSS software are doing it, Any ideas? maybe a service pack 2 issue or a .net framework issue?

    my blog is in spanish… and the rss doesn’t work…
    i try to see the file in explorer http://olivieri.tx.com.ru/wp/wp-rss2.php and it says that the á,é,í,ó,ú,..etc are no valid characters or something like that…
    how can i fix this??? help plz

    My rss feeds aren’t working in yahoo or in newsgator. They both state that it could not find a valid rss or rdf file.
    radio userland also can’t read the feed “Can’t subscribe to the channel. The most likely cure is to check the URL in a web browser and see if you can get it to read the feed. The following message probably won’t help you figure out what went wrong, but we include it here because it might. “rssAutoDetect”

    Any ideas?

    In looking at the result of my wp-rss2, I see that within content:encoded there is a <![CDATA[ before the actual blog content and ]]> after it. I don’t see this on my friend’s wordpress installation. I’m guessing he’s not running full feeds.
    End result is the same though, I’m using sauce reader and i’m unable to read my rss feed or anyone else who is running WordPress. Which sadly, due to my evangelism is pretty much everyone who isn’t on livejournal.
    Even though it looks like various readers are having problems, I’m going to pursue a resolution to this on the Sauce Reader forums in case its a problem with the program.



    I’m having the same problem with Sharpreader as the original poster. Anyone found the problem yet?


    I am also getting this problem. Feedster validates the feed, but Sharpreader doesn’t like it. I sent a bug report to Carl Hutteman who wrote Sharpreader to see if he could shed some light on the problem


    I use NewsGator, and my feed used to work, but for the last couple of weeks it hasn’t. I also get the error “Error: The underlying connection was closed: The server committed an HTTP protocol violation.”


    I’ve got problems with 404s and feeds. The 2 default URLs (http://endeavour.zapto.org/astro73/blog/feed/rss2/ and http://endeavour.zapto.org/astro73/blog/comments/feed/rss2/) I have not changed, but according to my server they don’t exist (and they don’t, nor are they in my local clean copy).
    Does .htaccess need to be enabled and present for this to work? And if yes, what does it need to be?


    I’m pretty sure the problem is that the feeds are sending out a malformed HTTP header (“Last Modified” as opposed to “Last-Modified”.) Anyone running the .Net framework 1.1 with SP1 will see this error.


    Yep – the post above got it right. Change the following code to fix the problem:
    Replace line 87 of wp-blog-header.php with:
    @header(‘Last-Modified: ‘.$wp_last_modified);
    Worked for me.


    I could be wrong, but I think that wp-1.2.1 addresses this.
    I have a newly-upgraded version of wp and it reads the correct “Last-Modified”, not “Last Modified”.

    It’s still broken in WP 1.2.1, but fixed in CVS.

    Thanks guys – that worked for me with Newsgator.

    I am trying to validate my rss feed but having problems. Here are the errors I get:

    This feed does not validate.


    Feeds should not be served with the “text/html” media type [help]


    Your feed appears to be encoded as “utf-8”, but your server is reporting “US-ASCII” [help]


    line 2, column 0: XML Parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]

    <?xml version=”1.0″ encoding=”UTF-8″?>

    Source: http://www.virtualtheology.org/wp-rss2.php

    2. <?xml version=”1.0″ encoding=”UTF-8″?>

    Any suggestions?


Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘[Resolved] RSS Feed Problems’ is closed to new replies.
Skip to toolbar