Support » Plugin: Woocommerce GlobalPay » return link 404error

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Feyisayo Akinboboye

    (@feyisayo)

    Hello tar112,
    Sorry this took a while. I am just seeing your post.

    Thanks for the compliment.

    The hyperlink you used points to http://room624.com/globalpay-transaction-response__?txnref=1-3188-1393544564&status=successful

    With this link, you get a 404 error.

    The link should have been http://room624.com/globalpay-transaction-response?txnref=1-3188-1393544564&status=successful

    I tried it and it took me to your homepage. This suggests that the return URL has not been properly configured on Zenith Bank’s end.

    So 2 things:
    1) Use the base link http://room624.com/globalpay-transaction-response and not http://room624.com/globalpay-transaction-response__

    2) Get in touch with Zenith bank and ensure that the URL they have configured as your return URL is http://room624.com/globalpay-transaction-response

    Good luck.

    Thanks Mr Feyisayo, the return link is working now. However i have another problem that may have to do with the update of woocommerce, mot sure but after it comes back to the return link link, i get this error:

    Warning: end() expects parameter 1 to be array, null given in /home/content/56/11998056/html/wp-content/plugins/woocommerce-globalpay/woocommerce-globalpay.php on line 355

    Warning: end() expects parameter 1 to be array, null given in /home/content/56/11998056/html/wp-content/plugins/woocommerce-globalpay/woocommerce-globalpay.php on line 357

    Warning: end() expects parameter 1 to be array, null given in /home/content/56/11998056/html/wp-content/plugins/woocommerce-globalpay/woocommerce-globalpay.php on line 358

    Warning: end() expects parameter 1 to be array, null given in /home/content/56/11998056/html/wp-content/plugins/woocommerce-globalpay/woocommerce-globalpay.php on line 359

    Warning: end() expects parameter 1 to be array, null given in /home/content/56/11998056/html/wp-content/plugins/woocommerce-globalpay/woocommerce-globalpay.php on line 360

    Warning: end() expects parameter 1 to be array, null given in /home/content/56/11998056/html/wp-content/plugins/woocommerce-globalpay/woocommerce-globalpay.php on line 361

    Sorry. Your payment was not successful

    What do you suppose could be the problem?
    Thanks again for your help

    Plugin Author Feyisayo Akinboboye

    (@feyisayo)

    Hello tar112,
    What version of WooCommerce are you using?

    i am using ver. 2.1.5

    Plugin Author Feyisayo Akinboboye

    (@feyisayo)

    Hello tar112,
    The plugin was tested with WooCommerce 2.1.2.

    I am yet to work on an upgrade to the plugin. I will do so in the coming weeks (3 to 4).

    If your needs require a shorter time period, you can post the job of upgrading the plugin on http://jobs.wordpress.net/ and let me know of it and I will give you a price.

    Ok thanks will do thanks

    hi,
    SO i downgrade to 2.1.2 and i’m still getting the same erors. even downgraded to 2.0.14 just to be sure and still the same. Even tried using a diffrent theme. seems there’s a problem consuming the array, My php is a bit limited.

    Plugin Author Feyisayo Akinboboye

    (@feyisayo)

    Hello tar112,
    I am currently in the middle of something. I will get back to you on this matter this week.

    Thank you

    Plugin Author Feyisayo Akinboboye

    (@feyisayo)

    Hello tar114,
    I have started work on the plugin, updating it for the latest WordPress and WooCommerce.

    The main problem of the error message has been fixed. I am now working on backend issues.

    You can get the latest code on Github at https://github.com/Feyisayo/woocommerce-globalpay/tree/dev

    However, do not use it on a production server as I still have some minor issues to fix on it.

    That should be done next week

    Thanks,
    and great job. really appreciate it.

    Don’t know if this helps but this is the response i got from the IT guys at zenith concerning the issue:

    I have checked the transaction on the demo server and can say it was successful. Please ensure that you are using the right web service username and password. Also note that you are meant to retrieve some details from your database to compare with amount.

    Thanks

    Plugin Author Feyisayo Akinboboye

    (@feyisayo)

    I can’t really put this response in context. However, GlobalPay has made a small change to their API. It turns out the small change has a big effect.

    I have made further changes to the dev branch of the code on Github. I have tested it and so far it works. You can try it out as well on a demo server.

    I will soon be releasing it on WordPress.org

    Best of luck

    Plugin Author Feyisayo Akinboboye

    (@feyisayo)

    I have just released the 3.1 version of the plugin. You can use that on a production server.

    It’s working now.
    Thanks for the update and welldone.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘return link 404error’ is closed to new replies.