Support » Plugins and Hacks » WP Ajaxify Comments » Replies not attached to main comment

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author janjonas

    (@janjonas)


    Could you please send me a link to the page where I can reproduce the problem?

    Plugin Author janjonas

    (@janjonas)


    Thanks for your comment. Are you sure that the problem is caused by the WP-Ajaxify-Comments plugin?

    You can use the browser console and test the result of $(“#comment_parent”).val(). After clicking a reply link the result is “0”, after clicking the same reply link again or another reply link, the result changes to a value > 0. In result, after clicking the reply link twice the comment should be saved correctly as reply (even with WP-Ajaxify-Comments enabled).

    Could you please test if you can reproduce this behavior and test if disabling the WP-Ajaxify-Comments plugin rely fixes the reply function (when clicking the reply link only ones)?

    Hope this helps…

    You’re right. Doing some more digging and checking comment_parent, I realize there were two of them. One from a hidden form, another from the real form.

    Turns out I had a spammer plugin that used a red herring form and this was interfering with comment replies.

    Didn’t notice this before because logged in users don’t get served the form and I was almost always logged in.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Replies not attached to main comment’ is closed to new replies.