Support » Plugin: W3 Total Cache » Render-blocking JavaScript:

Viewing 15 replies - 1 through 15 (of 33 total)
  • Oxhorn


    Hello, I too have this issue. I’m seeking to get my Google Page Speed score as close to 100% as possible. Any update on this?



    Any way we can get an expert to chime in on this one?



    I am in the same boat…

    So so close to google speed perfection.

    I would love an answer on this too.



    For JS,

    in Minify tab >> JS

    and choose Embed type non-blocking but there have no such option for CSS.



    Oh nice… I will try that… thanks longha!



    Yes I have this message on google speed test

    Eliminate external render-blocking Javascript and CSS in above-the-fold content
    Your page has 5 blocking script resources and 2 blocking CSS resources.

    It has been doing my nut in trying to find a solution, can someone pleeeeeeese give me some advise on exactly how I can rectify?

    Hello, In google developer page speed test i get the following error.
    Can any one help me in how to clear the following from the report?

    Eliminate render-blocking JavaScript and CSS in above-the-fold content

    Your page has 3 blocking script resources and 4 blocking CSS resources. This causes a delay in rendering your page.

    ■None of the above-the-fold content on your page could be rendered without waiting for the following resources to load. Try to defer or asynchronously load blocking resources, or inline the critical portions of those resources directly in the HTML.
    ■Remove render-blocking JavaScript:■

    ■Optimize CSS Delivery of the following:■

    I to am having render blocking javascript and css above the fold content issues.

    In addition, I need to leverage browser caching even though it is enabled in the W3 Total Cache settings. I tried adding this expires caching code to my .htaccess; however, it caused a 500 internal server error. I am assuming it is because the host provider does not have the mod_expires module enabled.

    Hoping someone out there has figured this one out.

    same issues here everyone, no answers yet, I have tried several plugins that say that they remove scripts in the header, no luck yet. will post something if I find.

    Looking for the same one.

    My score is horrible at 75.

    I too would like the answer

    So many people with the same problem and no answer.

    First of all, use non-blocking using Async in minfication settings.
    Also, not all render blocking code can be removed above the fold. This is why you want to use non-blocking with Async.

    I just posted in another thread with reco’d settings for minfication. You just can’t optimize all the code PSS reports on.

    Changing the js minify settings from default (blocking) to non-blocking using “async” reliably takes my Page Speed score down from 93 to 85. Maybe it’s just my setup, but I thought I’d just report that.

    … but Google Page Speed still recommends “Eliminate render-blocking JavaScript and CSS in above-the-fold content” for 10 resources. The only thing I can think of to do is to write code myself to deregister the resources and then load them in a different place, but that would be a hassle every time a plugin gets updated.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Render-blocking JavaScript:’ is closed to new replies.