WordPress.org

Support

Support » Plugins and Hacks » [Resolved] remove all comment forms from event pages

[Resolved] remove all comment forms from event pages

Viewing 13 replies - 1 through 13 (of 13 total)
  • caimin_nwl

    @caimin_nwl

    NetWebLogic Support

    Hi,

    You can disable comments from WP Admin by going to Events > Settings > Pages > Events Pages and setting Enable Comments? to No.

    already did that and its not working .

    caimin_nwl

    @caimin_nwl

    NetWebLogic Support

    Did you re-save the event you want to remove the comments from?

    yes i did . i wanted to try deleting it with the discussion option but don’t have it.
    how do i add the Discussions option of the events custom posts, so I’ll be able to Enable/Disable comments from there?

    caimin_nwl

    @caimin_nwl

    NetWebLogic Support

    You should be able to do this via Events > Settings > Pages > Events Pages . Are you using custom templates?

    did I not overcome this when I removed <?php comments_template(); ?>from page.php ?

    also, have you tried to edit your events and then uncheck “Allow comments.” under Discussion metabox ?

    at agelonwl _ I do not have access to the discussion tab ( its hidden for some reason)

    at mrpp- what do you mean? please be more clear and specific.

    Thanks for the help guys

    Hiya,

    If you can’t see the discussion tab you should be able to reveal it by clicking on Screen Options (top right corner) and then ticking the box labelled Discussion.

    That should restore the discussion settings box for you.

    Cheers,
    Phil

    Hi Philip,

    I already did that and it is not under the screen option neither.

    this is what i have when i click on screen options:

    Event Categories Bookings Stats Featured Image When Excerpt Custom Fields Slug Author WordPress SEO by Yoast Bookings/Registration Attributes
    Screen Layout

    Number of Columns:1 . 2

    caimin_nwl

    @caimin_nwl

    NetWebLogic Support

    Phil means the Screen Options box on individual events pages. Sounds like you’re looking at the one on the main Dashboard.

    I think i have not made myself clear.

    1)Under screen options I do not have the option to turn off comments.
    The following optionS are the only one i have : Event Categories Bookings Stats Featured Image When Excerpt Custom Fields Slug Author WordPress SEO by Yoast Bookings/Registration Attributes Screen Layout.

    2)under Dashborad/settings/discussion I do not have the otpions Enable and Disable Comments.

    So how do i fix this?

    thanks in advance for your valuable thoughts!

    Diena

    Plugin Author Marcus

    @netweblogic

    Hi Diena,

    Chances are you have to enable comments in EM first, disable comments in your older events, then disable comments again in EM and you’re set for future events you create.

    Once you enable comments, you can just bulk edit your events, i.e. click your Events admin page, select all your events, bulk edit (top left dropdown) and then turn off comments.

    The way WP works if you enable comments on individual posts, it remains enabled even if you turn off comments. Odd but that’s how it is.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] remove all comment forms from event pages’ is closed to new replies.