Support » Plugin: Related Posts by Sovrn » Related posts only showing one post now

  • Resolved schobeleth

    (@schobeleth)


    Hi everyone,

    I wanted to first give thanks for such a seamless and top notch plugin. It’s worked like a charm, and it automatically populated the proper amount of posts from my website, Niche Gamer, and suddenly it’s only populating one related post.

    When I try to manually add other posts from the site (which is not what I want to do), they aren’t even added either. Any suggestions? I haven’t updated anything, it just suddenly stopped working.

    https://wordpress.org/plugins/related-posts-by-zemanta/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hey, thanks for the nice words and your compliments, we truly appreciate it, but since this is a double repost msg, we would rather have this conversation continued over there, since the problems you described occurred with our other plugin: click!

    Hope you don’t mind, but I’m going to mark this topic as resolved (because of the same reasons as stated above).

    Take care & have a nice day!

    Best,
    Silvo

    Hey Silvo!

    Here are the screencaps for my settings:

    http://imgur.com/iQmrvBk,0rH1H0P#0
    http://imgur.com/iQmrvBk,0rH1H0P#1

    Nothing special, I used the vertical medium theme and haven’t touched the CSS. I also didn’t use the automatically embed beneath posts option, because it put it into a weird spot in my articles (as there is a lot of stuff below the content), so I used the custom shortcode:

    <?php wp_related_posts()?>

    Which was working beautifully, and it automatically grabbed posts from my site. By choosing posts manually, I did mean clicking the orange button and going in to choose related posts manually, and adding them to the article. That doesn’t seem to be working now either.

    I don’t really use that many plugins aside from cross posting plugins for FB/Twitter/etc, and a few layout changing plugins, but those are only for the desktop mode. Again thank you so much for looking into this.

    Hey, thanks for the screenshots, very much appreciated, although they are not that helpful to us as we hoped they would be. Nonetheless — big thanks for providing them to us!

    But you got our attention with that “and a few layout changing plugins” part — which plugins are managing that, if you don’t mind us asking?

    Also — which version of WordPress are you currently using? Have you made any recent changes to your WP Dashboard that might have caused these kind of problems, such as any plugin updates, new plugin installations, theme modifications, etc.?

    Any additional feedback is greatly appreciated! We’re eager to help you out! Take care & we’re looking forward to your reply!

    Best,
    Silvo

    I’m using wordpress 3.9.1, and the only plugins that I’m using that chance the core theme in any way are:

    WP-pagenavi (which just converts the page buttons a bit)
    Dynamic widgets (which just lets me choose when they pop up)
    … and that’s it I think.

    I could give you the list of all my plugins, the next thing I was going to try would be deactivating each one and see which one may or may not be the problem.

    The problem is I didn’t notice this until a day or two ago and now it’s affecting all of my posts, so I’m not sure when it started exactly, and which plugin may have affected it.

    Alright so I’ve realized that this problem only affects my regular posts, and not my custom posts. Any suggestions?

    Oops – I found the problem.

    WP Bitly was conflicting with it after I updated the plugin. Hoping the author of that plugin will update it to resolve whatever said issue is. Sorry to trouble you guys!

    Hey, sorry for not responding any sooner but I’m glad you got around your problem, really!

    Actually — we were just noticing those bitly links in your source code as well, which raised a couple of eyebrows on our end we and wanted to ask you more about it — but now it seems this was the actual culprit of your problem and thankfully you are on the right track to get it solved! Which is nice!

    Let us know how it ends up or if there’s anything that you need to be done from our side, since we’ll gladly help! Take care & have a nice rest of the day!

    Best,
    Silvo

    Oops – I found the problem.

    WP Bitly was conflicting with it after I updated the plugin. Hoping the author of that plugin will update it to resolve whatever said issue is. Sorry to trouble you guys!

    WP Bitly has been updated to 2.2.9 to revert the change that caused your issue. I’m working out a different solution to the problem it tried to solve, one that won’t conflict with an apparently large spectrum of other plugins.

    Thanks Mark, appreciate your input on this! Let us know if you need any assistance from our side or if you have any other questions what-so-ever, since we’ll gladly help!

    Here’s my contact address, if neccesary: support[at]zemanta[dot]com

    Take care & have a nice day!

    Best,
    Silvo

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Related posts only showing one post now’ is closed to new replies.