Support » Plugin: Contextual Related Posts » Related posts aren’t fetched automatically

  • I can manually select what related posts to display, but the plugin don’t do that automatically. I don’t know where I’m doing wrong.

    Btw, I’m looking for a button to export the settings, so that you can help easier. Perhaps you can consider that?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ajay

    (@ajay)

    I’m going to add the export/import settings option into one of the new versions.

    Separately, on the first part of your question, do you know if you have the FULLTEXT indices in the table properly set up? You might need to use Query Monitor to see what the queries are generated and their outputs

    I have installed it, but what can I do from here to know whether FULLTEXT exists?

    Plugin Author Ajay

    (@ajay)

    The best option is to visit a post that displays the related posts – then from the top select the Queries and Queries by Component and locate the ones by CRP. There will be one which generates list – you’ll find it has the MATCH keyword. Please make sure you have the CRP cache disabled in the plugin settings

    See a tutorial on this if you’re familiar – https://kinsta.com/blog/query-monitor/

    I find this exact error:

    Query Caller Component Error Message Error Code
    SELECT DISTINCT wp_posts.ID, wp_posts.post_date
    FROM wp_posts
    WHERE 1=1
    AND MATCH (post_title) AGAINST (‘Recommended software’)
    AND wp_posts.post_date < ‘2019-08-08 16:48:12’
    AND wp_posts.post_date >= ‘2016-08-08 16:48:12’
    AND wp_posts.post_status = ‘publish’
    AND wp_posts.ID != 1117
    AND wp_posts.post_type IN (‘post’, ‘page’)
    LIMIT 0, 6

    get_crp_posts_id()

    Plugin: contextual-related-posts The used table type doesn’t support FULLTEXT indexes 1214

    The page is http://lyminhnhat.com/resources/productivity/recommended-software/

    Plugin Author Ajay

    (@ajay)

    Thanks. It seems like you might have an older version of mySQL that doesn’t support the FULLTEXT indices which is why you’re getting that error.

    This could be because your table is innoDB in an older version. Could you be able to check with your host which version you have and if you can upgrade it.

    Another alternative is to convert the table to myISAM which would allow you to create the fulltext indices.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.