Support » Plugins and Hacks » Redirection Plugin Not Working

  • Hi, we are attempting to set up 301 Redirects on a site we have recently put live and we are using the Redirection plugin V2.2.3 – The latest version.

    We are able to install the plugin and add some URL’s but none of the URL’s will redirect to the intended destination URL! We have tried testing on a local and live version and nothing. We are always just redirected to a 404 page. The URL added never gets any hits tracking etc.

    Has anyone got any light on this in terms of broken Redirection plugin with WP 3.1?

    Also, there is an error message constantly displaying in the error logs but I don’t think this is to do with the redirection plugin.

    [10-Mar-2011 08:15:27] PHP Warning:  Module 'apc' already loaded in Unknown on line 0

Viewing 15 replies - 1 through 15 (of 18 total)
  • A H

    (@arlo-haskell)

    It’s not working for us either. The first few redirects worked fine, but can’t get anything else to redirect after that. One of them started working after I toggled it off and on, but the others still don’t work. I see either the code for the old page or a 404.

    Is this thing broken?

    Using v2.2.3 in WordPress 3.1

    I am using WP 3.1 and version 2.2.3 successfully for simple 301 redirects.

    Most are specific page redirects, but a few are out of date directories.

    In the Target URL I use page ids.

    /?page_id=1288

    The HTTP code is 301.

    Perhaps you need to restart the http daemon (web server) so the .htaccess file is loaded.

    I’m having the same problem using 2.2.5 and WordPress 3.04. The first few redirects work fine, but after that nothing is working! I’m using the WordPress module! Is this a bug that needs to be fixed?

    Aseem, what do you mean your first few redirects work? You have a redirect that works for a few times and then stops, or you have a few redirects that always work, but any new redirect you add doesnt?

    Hi John,

    Sorry for the late reply, I did not get a notification that you replied!

    Anyway, the first few redirects work all the time, but after the first 4 redirects that I manually added, the others simply do not work at all.

    And under the Hits, if I visit any of the first four redirected URLs, it shows up as a hit (the number increases).

    However, when I visit the ones that don’t work, it doesn’t show up as a hit either. So for whatever reason, the plugin is not recognizing the source URL and therefore is not redirecting nor logging it as a hit.

    If you need any other information about my setup, please let me know.

    Thanks for your help!

    Aseem

    Hi John,

    Just curious if you had a chance to look at this issue? Any other info I could provide to help fix it?

    Thanks man!

    Aseem

    There’s not a lot I can suggest based upon the information so far. If you could list the redirects here, or send them to my website, then that may help.

    Using WordPress 3.1.2 and v2.2.5 of the plugin, installation went without a hitch, the plugin is detecting 404 issues, I can create the redirects but they don’t work: whenever I call one of the page for which I set up a redirect link, I get error 404.
    Is there a way to debug?

    I am using WordPress 3.1.2 and v2.2.5 of the plugin. The redirects work perfectly, but when I enter my URL into my browser (Firefox 4.0) the page comes up white. If I search for a specific post or product review it comes up.

    Can’t seem to find a setting to change. Anyone else having this issue?

    plugin 2.2.5 doesn’t work for me too

    my wordpress version is 3.1.2

    I’m having the exact same problem as FascinantJapon:

    – WordPress 3.1.2 and v.2.2.5 installation perfect

    404 detection module a-ok

    – I’ve created a few simple redirects but i continue to get 404 errors

    – I’ve had success with other redirect plugins but really like the functionality of “block” redirection.

    I’m happy to support the plugin financially if i can get working on my server…

    Ok, with some fiddling i’ve figured out the following

    If I just want to redirect a single URL, then if I use the FULL target URL the redirect works

    e.g.

    Source URL: /blog/
    Target URL: http://www.mysite.com/news/

    works fine

    but

    Source URL: /blog/
    Target URL: /news/

    does not work

    Also note:
    if you use something like

    Source URL: /blog/(.*)
    Target URL: /$1

    that’s a regular expression and you have to check the regex box (yes, it says it in the documentation, but for those of us who have a hard time reading…)

    I hope this is helpful to others with the same “problems”

    all right, “final” post here.

    I can get all sorts of redirects working (both regular expressions and strings) EXCEPT a generic redirect from

    http://www.mysite.com/blog/11/2007/post_name/
    http://www.mysite.com/post_name/`

    Here is the code that I’m using — maybe I’m missing something?

    target: /blog/(d*)/(d*)/(.*)
    source: /$3

    note:

    ​/blog​/2011​/03​/(.*)
    /$1

    works fine

    but

    /blog/2011/(d*)/(.*)
    /$2

    does not

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Redirection Plugin Not Working’ is closed to new replies.