Support » Fixing WordPress » Redirecting to Deleted wordpress.com blog

  • The wordpress.org site thinkinaboutdiamonds.com was recently built for me by a colleague (via hostgator). For a week it functioned well, but this past weekend we started receiving the error message that “thinkinaboutdiamonds.wordpress.com” no longer exists.

    This is where I think the problem may originate: I first had the wordpress.com site thinkinaboutdiamonds.wordpress.com. We had thiis redirected to the domain thinkinaboutdiamonds.com. However, we then reached the decision to make an actual thinkinaboutdiamonds site through wordpress.org. In order to do that, my colleague had to request that “thinkinaboutdiamonds.com” be deleted.

    Once she received confirmation that the domain name had been cancelled, she created the actual thinkinaboutdiamonds.com site on wordpress.org and it worked well. Once the site was up and functional I deleted thinkinaboutdiamonds.wordpress.com blog to avoid confusion. Apparently now that it has been deleted, it acts as though thinkinaboutdiamonds.com is only the domain name that the blog is supposed to redirect to and now that the blog has been deleted, it has nothing to redirect to.

    I hope that this all make sense. Basically what is happening is that we can’t get to the homepage of the thinkinaboutdiamonds.com site b/c it redirects to thinkinaboutdiamonds.wordpress.com site that has been deleted. We are able to go to other pages on thethinkinaboutdiamonds.com site by using specific URLs.

    I look forward to your response. Any help would be greatly appreciated.

    Sincerely, Liza

Viewing 3 replies - 1 through 3 (of 3 total)
  • It appears you have a redirect or something on your page. You can get to the admin site of your blog by going to:

    thinkinaboutdiamonds.com/wp-admin/

    Once you login to the admin take a look at the Settings page, report what the WordPress URL and the Site URL are back on this post. Also note the URL in your browser when you login.

    Actually looking a little closer, I think the issue may be in your index.php file in the root directory. Or it might be an index.html file (update it’s not that).

    My best guess is it’s something in your index.php file. The entire contents of your index.php file should be:

    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define('WP_USE_THEMES', true);
    
    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>

    If you see something else, post it here and I might be able to troubleshoot it, if not you might try to replace your contents with what I posted and see if that fixes it. Or have your colleague do it if this sounds too technical.

    Hi, thank you for the suggestions. Unfortunately, that doesn’t seem to be the problem. That index.php file said:

    <?php
    /**
    * Front to the WordPress application. This file doesn’t do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define(‘WP_USE_THEMES’, true);

    /** Loads the WordPress Environment and Template */
    require(‘./wp-blog-header.php’);
    ?>

    We replaced it with what was suggested. When all history and cache were cleared and we entered the URL “thinkinaboutdiamonds.com” it went to .wordpress.com again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Redirecting to Deleted wordpress.com blog’ is closed to new replies.