Support » Plugin: Testimonial Basics » Random always shows the same

  • I took the example shortcode and changed the number to two. I have 6 testimonials. Whenever the page loads it’s alsways the same two. Is there a way to get it to randomly display testimonials?

    [katb_testimonial group=”all” number=”2″ by=”random” id=”” rotate=”no” layout=”0″ schema=”default”]

Viewing 5 replies - 1 through 5 (of 5 total)
  • The widget seems to be the same. I selected Random and show 4, it always shows the first 4.

    Plugin Author kevinhaig

    (@kevinhaig)

    It is working on my test bed. Perhaps it is a cache issue. Try testing with your cache disabled.

    It’s very strange, on a different site I work on it’s working just fine. On this one it doesn’t work and I’ve disabled all other plugins and switched to the TwentySixteen theme. It is hosted with WP Engine and they do a lot of caching, but I tried it on the staging version too which supposedly has no caching. I’m going to contact them, but if you have any ideas please let me know. Thanks for the help.

    You may want to make sure that “Allow ORDER BY RAND()” is enabled in WP Engine > General Settings:

    Allow ORDER BY RAND()

    • This reply was modified 2 years, 3 months ago by  Jason Cosper.

    @boogah that was the problem thanks.

    • This reply was modified 2 years, 3 months ago by  winterstreet.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Random always shows the same’ is closed to new replies.