Support » Plugin: WP Store Locator » Radius field not working

  • Hi,

    Radius field is not working anymore. It use to be working !!

    I did deactivate all plugins but still not working.

    Actually, I could live without it, if it can be disabled in some way.

    Thanks for your support

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter pictogram

    (@pictogram)

    Sorry,

    here is a working URL : https://dev.canardgoulu.com/points-de-vente/

    Thanks

    Plugin Author Tijmen Smit

    (@tijmensmit)

    The correct radius parameter is included in the AJAX request, so that part is working well. Did you customize any of the code? Where are the locations located outside of Quebec?

    Thread Starter pictogram

    (@pictogram)

    Thanks Tijmen for your support,

    Actually I found that it is working everywhere on the map except on the default point and near the default.

    You can try with default location located in Québec city. If you enter a zip code near Québec, for example G6V 5A5, radius won’t work. At least not on my side.

    My client doesn’t have any store outside province of Québec.

    Thread Starter pictogram

    (@pictogram)

    Hi,

    Radius is still not working as expected, see video : https://www.useloom.com/share/0697bb2c5e8b40daba8a6c2cb3eac366

    Live install at https://dev.canardgoulu.com/points-de-vente/

    Thanks

    Plugin Author Tijmen Smit

    (@tijmensmit)

    The problem seems to be that you increase the max search radius, but not the max search results. It’s hard to see in the video, but I’m sure that I can count 25 locations ( the marker cluster number + the individual ones ) after your search.

    So increasing the radius, but not the max results ( once it’s reached ) will indeed not show more on the map.

    Thread Starter pictogram

    (@pictogram)

    Mmm !

    Shouldn’t that “max search results” increase/decrease accordingly with increase/decrease radius and the other way around too ?? That’s what I would expect when zooming in or out actually .

    What I did is uncheck “Show the max results dropdown?” and set “Max search results” to [500]. That way, if a location is entered, zooming in/out with radius dropdown will work and display stores accordingly, but forces large display of map, even if 25 km is set.

    Default location will display but won’t allow zooming in/out with radius without entering a location.
    And if I zoom in/out with mouse, I won’t get stores located outside default view point.

    IMO, seems like radius and results should be in sync in some way.

    Thanks for your support

    • This reply was modified 2 years, 7 months ago by pictogram.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Radius field not working’ is closed to new replies.