Support » Plugin: Quick Cache (Speed Without Compromise) » Problems with QuickCache

  • Using Quick Cache on my sites for ages… noted that it seems to have fewer & fewer features on each update… and more & more problems.

    Currently, I have two sites on the same server: both with QC installed. One is fine; one throws errors. I still like the plugin, but will be trying others to fix the issues.

    I appreciate the coding for this plugin takes effort… Good luck.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Raam Dev

    (@raamdev)

    noted that it seems to have fewer & fewer features on each update… and more & more problems.

    • v140605: 8 new features, 6 enhancements, and 4 bug fixes.
    • v140725: 1 new feature, 4 enhancements, and 10 bug fixes.
    • v140104: 2 new features.
    • v131224: 5 enhancements, 5 bug fixes.

    As you can see, we’re constantly adding features, enhancements, and fixing bugs, so I’m not sure where you get the idea that the plugin “seems to have fewer & fewer features on each update”.

    Currently, I have two sites on the same server: both with QC installed. One is fine; one throws errors.

    Since the Quick Cache code is obviously the same on both sites, the problem is more likely another plugin that is not common to both sites, or a configuration difference between the two sites. The fact that you have Quick Cache running on both sites and one has issues and one doesn’t is pretty good evidence that Quick Cache isn’t the problem at all.

    Perhaps the simplicity of the menu options hides its complexity.

    The plugins were a subset of the plugins on the other site. I will do a thorough examination. Let you know.

    OK. Error reported:

    “You’re currently running PHP v5.2.17. A simple update is necessary. Please ask your web hosting company to do this for you. To remove this message, please deactivate Quick Cache.”

    I can confirm that I’m running PHP version 5.4.x. I tried downgrading to 5.3.x to see what happens. BUT the primary site is running 5.4.x just fine.

    Plugin Author Raam Dev

    (@raamdev)

    I can confirm that I’m running PHP version 5.4.x. I tried downgrading to 5.3.x to see what happens. BUT the primary site is running 5.4.x just fine.

    I’ve seen this on a few sites that appear to have PHP 5.3+ installed, but in the server configuration itself PHP v5.2 is actually being used. You may want to contact your web hosting company to verify that PHP 5.3+ is running.

    Another way you can test is by creating a PHP file with the following code and accessing it in your browser. This is essentially the code that Quick Cache uses to verify you’re running PHP 5.3+:

    <?php
    if(version_compare(PHP_VERSION, '5.3', '>='))
    	echo "You are running PHP 5.3+";
    else
    	echo "You are NOT running PHP 5.3+! Your current PHP version is " . PHP_VERSION;

    I got 5.2+ for one and 5.3 for the other. Two sites (same server)… will have to contact my hosting company. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problems with QuickCache’ is closed to new replies.