Support » Plugin: WordPress Gallery MaxGalleria » Problems with national characters

  • Resolved photopidenmark

    (@photopidenmark)


    Hi MaxGalleria

    After the latest update, I realized that national characters, Danish, Icelandic are no longer presented correctly? The problem is located to caption only. Alt text works fine. I have tetstet updating caption on different computers, win 07, win 10, Chrome, Internet Explore with the same result.
    I take a lot of pictures on Iceland and like to name them correctly in Icelandic using caption. I hope you can resolve the matter. Please let me know what you need and if we need to move to support on MaxGalleria.com

    Best Regards
    Morten Nissen

    • This topic was modified 4 months ago by  photopidenmark. Reason: Editing title

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • photopidenmark

    (@photopidenmark)

    Hi MaxGalleria

    I have tried to update caption through phpMyadmin Table: www_post, post_excerpt. This seems to work fine for both danish and icelandic characters. To me it might indicate a js-issue as the root of the problem? I hope you will have a chance to look in to it soon.

    Best Regards
    Morten Nissen

    Plugin Author AlanP57

    (@alanp57)

    Can you provide an example of the text you are entering so I can see what is happening?

    Hi Alan
    Of course.
    The procedure is:
    1. Enter MaxGalleria through the back end
    2. Select Edit Bulk Images
    3. Enter the text: Valahnúkamöl in caption
    4. Press save changes
    This results in caption being updated to: Valahnúkamöl
    It is possible to correct this through phpMyadmin so caption again contains the correct text: Valahnúkamöl

    Best Regards
    Morten

    Plugin Author AlanP57

    (@alanp57)

    Thank you, I’ll see if I can find a solution.

    • This reply was modified 3 months, 4 weeks ago by  AlanP57.

    Hi,
    same problem now (from last update) with Russian characters. It’s possible to write caption’s text in Russian within description of picture in Media Library Folders. And it is displayed correctli also in Max Gallery. But when I’m trying to change this text in Gallery, after pressing Save changes all characters are replaced with something from other characters set…

    Plugin Author AlanP57

    (@alanp57)

    I’ve not found a way to programmatically fix this type of issue. Understand that you web site and your database have character sets settings that are related to this issue. You would need to insure that these settings are in harmony with the language in use.

    Hi Alan

    Okay. Do you have any recommendations for the language settings of the database? I just find it strange that is is possible to correct it via PhpMydadmin, if it is a database issue? It also seems to affect many other national characters like russian?
    Do you have any idea why this only affects caption? Alt text works fine

    Best Regards From Copenhagen

    Plugin Author AlanP57

    (@alanp57)

    Ok, since ‘Alt text works fine’, then the issue must be with the function we use to remove selected HTML tags from the fields. We have now released version 6.1.2 that address this issue.

    Hi Alan
    Everything seems to work fine after the latest update.

    Thank you for resolving it

    Have a nice tuesday
    Best Regards From Copenhagen.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.