Support » Plugin: BlipPress » Problems with authentication

  • Resolved bugjemm

    (@bugjemm)


    When I try to ‘Grant authentication’ to Blipfoto via BlipPress, I get the following error message.

    Warning: Cannot modify header information – headers already sent by (output started at /var/sites/b/bugjemm.net/public_html/wp-admin/includes/template.php:1692) in /var/sites/b/bugjemm.net/public_html/wp-content/plugins/blippress/inc/blipfoto-wordpress-api.php on line 114

    Any suggestions to help?

    http://wordpress.org/plugins/blippress/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Simon Blackbourn

    (@lumpysimon)

    Hi

    This looks very much like a conflict caused by another theme or plugin on your site.

    Can you please try disabling your plugins one at a time, and after each disablement try the authentication again. If authentication is successful, let me know which plugin you disabled immediately before. I can then look at that plugin’s source code to determine what caused the conflict.

    If that doesn’t work, try changing themes. If that solves it, let me know the name of the theme that caused the problem.

    Sorry it’s a bit of a pain to do all this, but hopefully this process of elimination will get to the bottom of it.

    Simon

    Hiya

    I’ve deactivated every plug-in except WordPress and switched between four different themes. Same error message every time 🙁

    Jemm

    Plugin Author Simon Blackbourn

    (@lumpysimon)

    I’m not sure of your level of technical ability, so I have no idea if the following will make any sense…

    One possible cause is if one of your PHP files has a space after a closing ?> tag at the end of the file. Have you (or someone else) edited any PHP files?

    If you have access to your wp-config.php file, can you check if any of the debug constants are defined in there? e.g. define( 'WP_DEBUG', true );

    Or does your hosting server have display_errors turned on in the PHP config? (this is very unlikely but I’m clutching at straws!)

    Any of these could generate output to the screen before the page loads, which could cause this problem.

    It’s safe to say my technical ability is approaching zero – well, maybe 0.5.

    I’ve not, to my knowledge, edited any php files and no one else has access to my WordPress site, but it was recently moved across from WordPress hosting to self-hosting on my own domain via the WordPress import Plugin, after being neglected for a long time, just in case that gives you a clue. I hadn’t tried to install your Plugin before it was moved and it was actually one of the first (but not the actual first) I installed and tried to authenticate once I’d made the move. I’ve not had similar problems with any of the other Plugins 🙁 Am I ok to reactivate them now?

    I’ve just located the wp-config.php file and it says
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define(‘WP_DEBUG’, false);

    Is the ‘display_errors’ going to be in the same file? If not, where am I likely to find it in my hosting File Manager?

    Plugin Author Simon Blackbourn

    (@lumpysimon)

    The debug value in the wp-config.php file is fine.

    Let me do some more investigation and I will get back to you as soon as possible.

    You can re-activate your plugins/theme for now.

    One more question: does the error message display immediately after you click the ‘authenticate’ button, or does it send you to blipfoto.com first and then show the error?

    Ta re re-activation.

    The message appears immediately when I click the authenticate button, definitely goes nowhere near Blipfoto.com, and BlipPress doesn’t appear in my Blipfoto apps page either.

    🙂

    Plugin Author Simon Blackbourn

    (@lumpysimon)

    Thanks very much for all your help over email, it really helped in pinpointing the cause of this one.

    This is now fixed in version 0.2.1.

    Happy Blipping!

    Thanks for sorting it out so quickly, Simon – looking forward to using it now!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problems with authentication’ is closed to new replies.