Support » Plugin: WPCargo Track & Trace » Problem with plugin activation

  • Resolved denis_ryabikov

    (@denis_ryabikov)


    We have a problem with plugin activation.
    After we click on activation button into the plugins list we catch error (and plugin activation break on it):
    Parse error: syntax error, unexpected ':' in /home/virtwww/w_spbaero-com_424a83f8/http/wp-content/plugins/wpcargo/shortcodes/WPCargo-Track-Results.php on line 49
    Plugin version: 1.0.2

    https://wordpress.org/plugins/wpcargo/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Arni Cinco

    (@wptaskforce)

    Hi denis_ryabikov, Please check the version of your PHP.
    The Minimum Requirement is 5.4.45 if your version is below the minimum requirement please upgrade the version.

    I think that line is – ” $shipments = get_post_meta($trackid, 'wpcargo_shipments_update', true) ?: array();

    for now you can change it to – ” $shipments = get_post_meta($trackid, 'wpcargo_shipments_update', true);

    Thanks!

    denis_ryabikov

    (@denis_ryabikov)

    Hi, thx for fast response. Request on PHP update on our hosting successfully resolve this problem.

    Arni Cinco, please I have similar problem with the wpcargo plugin this is what I get in trying to activate the plugin

    “Parse error: syntax error, unexpected ‘:’ in /home/locust/public_html/wp-content/plugins/wpcargo/shortcodes/WPCargo-Track-Results.php on line 95”

    I can confirm to you that, I have upgraded my php up to the minimum requirement and the problem persist. Thank you for any assistance

    Plugin Author Arni Cinco

    (@wptaskforce)

    Hi Parikinit!

    The alternative solution for that is to change the code..

    Have you tried to change the code above?

    I think that line is – " $shipments = get_post_meta($trackid, 'wpcargo_shipments_update', true) ?: array(); "

    for now you can change it to – " $shipments = get_post_meta($trackid, 'wpcargo_shipments_update', true); "

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with plugin activation’ is closed to new replies.