WordPress.org

Support

Support » Plugins and Hacks » OGraphr for WordPress » [Resolved] Problem with [mixcloud] shortcode

[Resolved] Problem with [mixcloud] shortcode

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author idleberg

    @yathosho

    the maker of mixcloud embed should probably be more strict about the syntax, but it was easy to add a little tolerance to my plugin. as i’m working on the next major version right now, you’ll have to use this private built for the moment.

    http://dl.dropbox.com/u/353649/meta-ographr-0.7.12.zip

    please let me know if it gives you any troubles.

    Sorry but don’t work, the problem is the same 🙁

    Plugin Author idleberg

    @yathosho

    hm, it works for me (and didn’t before). could you give me an example for a shortcode you’re using?

    edit: i just upgraded from mixcloud embed 1.4 to 1.5 – now it’s no longer working. there are a couple of other things that broke since the upgrade, in my case the player is positioned at the wrong place.

    Plugin Author idleberg

    @yathosho

    when you compare an embed code produced by the mixcloud website with the one create by the mixcloud embed plugin, you will notice that the former uses url encoding (%2F for a slash) and the latter does not (/ for a slash). what i did first was increasing the tolerance of ographr to accept both, but i’m not sure why it stopped working after the update to mixcloud embed 1.5. for some reason, mixcloud embed now places the player twice into my page, first in the head of the page (!) and a second time in the top of my post (even though it should’ve been in third place on my test page!) you should probably contact the author of that plugin instead.

    you’re right, I try to correct the mistake! thanks for the tip!

    the version 1.5 is correct for the mixcloud embed plugin because I have rewrite all the plugin system. But I can modify the logic for a url encoding e retry.

    I have release a 1.5.1 version to resolve the problem of the urlencode, but the problem about your plugin is the same ?!?!

    Plugin Author idleberg

    @yathosho

    could you please

    1. tell me what happens when you embed a standard embed code?
    2. post the shortcode you’ve been trying to use

    you can view the problem here:

    http://www.bjtliveset.com/march-2013-techno-mix/

    the shortcode that i have used is:

    [mixcloud height=”200″ width=”100%”]http://www.mixcloud.com/BJT/bjt-march-2013-techno-mix/[/mixcloud]

    the problem is that the mixcloud embed code is copied in the head section!

    thanks for the patience

    Plugin Author idleberg

    @yathosho

    the problem is that the mixcloud embed code is copied in the head section!

    but only in the 1.5 versions of your plugin, in 1.4 everything is fine. i can’t really say if that causes the problem, but since the detection works flawlessly when using the old mixcloud embed, the problem must be in your plugin.

    did you also test what happens when you a standard embed code (=not the shortcode)?

    Hi
    I have resolved the problem. It’s an error of the shortcode of mixcloud embed. Because the code was printing with a echo e not returned to the parent function.

    Thankx for your support!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Problem with [mixcloud] shortcode’ is closed to new replies.
Skip to toolbar