WordPress.org

Support

Support » Plugins and Hacks » [Resolved] problem with array

[Resolved] problem with array

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Robin W

    @robin-w

    There is an error that is occurring with very few users (3 so far) of the latest version.

    I have not tracked down why yet, but can you revert to the previous version 1.8.1 which is here

    bbp Private Groups

    you need to download version 1.8.1

    If you are available to do some simple tests to help me eliminate this, please come back.

    It runs! thank you very much.

    I need to inser a user in multiple group, is it possible? how?

    Plugin Author Robin W

    @robin-w

    users only belong to one group.

    Forums have multiple groups associated with them

    what are you trying to achieve? Describe please !

    Plugin Author Robin W

    @robin-w

    pooyasas

    I am still trying to track down your original error, which I can’t replicate on my test site, and only two others have seen this.

    Would it be possible for you to test a different version of the plugin? You’d just need to install, switch to this version and see if the error is there or not, and then switch back – I’ll give you full instructions. Let me know.

    Getting this error after I updated to the latest version Version 1.9.1 now I’m not seeing the main forum landing page. I did nothing else but click the auto update. 🙁

    Warning: array_merge(): Argument #2 is not an array in /home/content/p3nexnas05_data01/83/2102083/html/wp-content/plugins/bbpress/includes/common/functions.php on line 1344

    Plugin Author Robin W

    @robin-w

    There is an error that is occurring with very few users (4 so far) of the latest version.

    I have not tracked down why yet, but can you revert to the previous version 1.8.1 which is here

    bbp Private Groups

    you need to download version 1.8.1

    If you are available to do some simple tests to help me eliminate this, please come back. Until someone helps me, I’m afraid you’ll need to stick at 1.8.1.

    I’ll help you test, just let me know what you’d like me to try. Just from reading the posts above me, I’ll for now assume you’d like me ti install the older version then re-update that to the new one just to see what happens? Correct?

    I’ll try that right now, if you need something else done just drop me another post.

    Ok, I fully deactivated AND uninstalled the new version, uploaded, installed and activated the 1.8.1 version and no problem what so ever.

    EVEN the original settings were there again although I flushed the cache and everything. My 8 groups that I created in 1.8.1 was also there. Not certain how all this set itself back up to what I had originally set it to, but it did.

    Once I made sure 1.8.1 was working exactly like it was before, I then clicked to update to the newer version. I then loaded my forum in a new page and got that same exact error once again.

    Hope this helps!

    Plugin Author Robin W

    @robin-w

    Zdev1, brilliant, thanks for doing that, it proves that I have got it wrong somewhere. That it is only affecting some users probably means it is in combination with something else, but whatever the cause, it needs fixing !

    Ok I did several changes between 1.8.1 and 1.9.1, and I need to work out which of these is causing the problem.

    Can you do the following for me?

    I have therefore made a version that contains some of the changes, and if you are happy to help, it would be great if you could try this version to see if the error remains or goes away. After that I would need you to do the same probably a couple more times just to get to a resolution.

    This will enable you to take advantage of the improvements which I plan for this plugin.

    Could you therefore follow these instructions – it may help to print them

    1. Go to the following site and download and save the test version to your PC, making a note of which directory you save it in.
    http://www.rewweb.co.uk/private-groups-plugin-test-version
    2. Go into your website and go into
    a. Dashboard>plugins>add new plugin>upload and browse to the file you just saved
    b. Click install now, BUT DO NOT CLICK ‘ACTIVATE’ AFTER THIS STEP
    c. Click ‘return to plugins page’
    d. You will see that you now have the original ‘bbp private groups’ plugin and a new ‘bbp private groups test’
    e. Deactivate the original ‘bbp private groups’
    f. Activate the new ‘bbp private groups test’
    3. Then test to see if this works without error
    4. Then deactivate the ‘bbp private groups test’ and activate the ‘bbp private groups’ so that you have a working site again.

    Then let me know if the test version worked without error, or whether it still had the same error (or indeed a different error).

    This will let me know which 50% of my changes are fine, and which I need to test further.

    You help will help me resolve this error.

    Robin, I followed your instructions exactly as you said, and I got no errors with the ‘bbp private groups test’ at all. I looked into each and every forum just trying to find anything out of the norm, but it was perfect.

    I have no deactivated test plugin and reactivated 1.8.1. again.

    By the way, I did this 3 times just in case.

    TYPO – “I have no deactivated test plugin” needs to read I have NOW deactivated test plugin. Sorry about that. 🙂

    I’m excited now to see what you make of this!

    Plugin Author Robin W

    @robin-w

    Brilliant, thanks for your help. That has eliminated half the changes I made, now I just need to go through the other changes and do the same process. ie change 1/2 back and get you to test again. I’ll see which I fancy may be causing the issue – I’ll come back shortly !

    Thanks again !

    Plugin Author Robin W

    @robin-w

    ok, I’ve created another test version, so can you delete the current test version plugin and then exactly as before (except its now called test2) :

    1. Go to the following site and download and save the test version to your PC, making a note of which directory you save it in.
    http://www.rewweb.co.uk/private-groups-plugin-test-version
    2. Go into your website and go into
    a. Dashboard>plugins>add new plugin>upload and browse to the file you just saved
    b. Click install now, BUT DO NOT CLICK ‘ACTIVATE’ AFTER THIS STEP
    c. Click ‘return to plugins page’
    d. You will see that you now have the original ‘bbp private groups’ plugin and a new ‘bbp private groups test2’
    e. Deactivate the original ‘bbp private groups’
    f. Activate the new ‘bbp private groups test2’
    3. Then test to see if this works without error
    4. Then deactivate the ‘bbp private groups test2’ and activate the ‘bbp private groups’ so that you have a working site again.

    Again, please let me know the result, and thanks again for helping !!

    Done, and got this error. I think it’s exactly as the one I was getting:

    Warning: array_merge(): Argument #2 is not an array in /home/content/p3nexnas05_data01/83/2102083/html/wp-content/plugins/bbpress/includes/common/functions.php on line 1344

    Keep in mind, the only thing I’m not seeing is the main forum landing page. I can click on any forum, post or entry following the Recent Posts and Recent Replies links in the sidebar, but can’t get to them from landing page.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] problem with array’ is closed to new replies.