Support » Networking WordPress » Problem migrating Multisite

  • Resolved ckassel


    I have read all of the topics regarding moving Multisite to a new domain and I did not see the problem I’m having.

    I copied my database and files and I updated the database using the interconnectit tool. I then got “Error Connecting to Database.” I went into my database through PHPMyAdmin and made sure I had updated the contents of the wp_blogs, wp_site, wp_sitemeta, etc., as well as the relevant numbered blog tables. I also made sure that wp-config and .htaccess files were set up properly for multisite with the proper domain etc.

    I did a database repair and got this message:

    wp_posts: Table ‘foo.wp_posts’ doesn’t exist
    wp_comments: Table ‘foo.wp_comments’ doesn’t exist
    wp_links: Table foo.wp_links’ doesn’t exist
    wp_options: Table ‘foo.wp_options’ doesn’t exist
    wp_postmeta: Table foo.wp_postmeta’ doesn’t exist
    wp_terms: Table ‘foo.wp_terms’ doesn’t exist
    wp_term_taxonomy: Table ‘foo.wp_term_taxonomy’ doesn’t exist
    wp_term_relationships: Table ‘foo.wp_term_relationships’ doesn’t exist
    wp_commentmeta: Table ‘foo.wp_commentmeta’ doesn’t exist

    where “foo” is a placeholder for my actual database name.

    What I don’t understand is: why does it think I need those tables? It is true that they don’t exist – because it’s a multisite setup!! So where do I go to tell it not to look for those tables but to look for the associated numbered tables that correspond to each blog in the network?

    Thank you in advance for any help you can provide.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    In your wp-config.php, do you have BOTH of these lines:

    define('WP_ALLOW_MULTISITE', true);
     define('MULTISITE', true);

    Those tables should exist, by the way, unless you started your site on WPMU…



    Contributor Day Volunteer

    Two things come to mind: one is what Mika alluded to, that you could possibly have database tables from wpmu, which would look like wp_1_posts, but perhaps a more likely scenario could be that on the db that you imported, the prefix was renamed something other than wp_, but in the wp-config you still have the prefix as the default wp_.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Actually, what I was thinking was that if you’re missing one of those lines, WP thinks it used to be WPMU, and actually looks for the wp_1 tables 🙂 If you never used WPMU, you should have both lines and WP will never look for wp_1

    Thank you so much for your responses! In fact, this site WAS a WPMU site. I believe it started with version 2.7 or so. It’s been around a long time. If you have quick advice for me, based on this information, let me know. Otherwise, I’ll keep digging. Thanks!

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Do you have both of the define lines I mentioned?

    And is there a wp_1 tableset? 🙂

    Well, I did have both of those lines… but then I did some comparisons of the old wp-config and the new one.

    Those of you who know this won’t be surprised, but apparently, the instructions for upgrading WPMU version 2.x to WordPress version 3.0 were to make a few adjustments to wp-config and to .htaccess. This did not convert a WPMU install to the new WordPress multisite model. I can’t believe this is how it was done, but it is. So every subsequent upgrade works, but it never actually converts the WPMU setup to a multisite install.

    When I tried to migrate the site to another host, I first set up WordPress multisite as a shell and then attempted to import the content into it. This will not work! It’s possible that it could work if you export and import each blog, but in my case, I had a plugin (CommentPress) that breaks if you do an export/import on the content.

    So here’s what I did instead: 1) Created an empty database. 2) Imported my database into it. 3) Copied over all my files. 4) Used the search-replace tool to update the database with the new URL. 5) Went into PHPMyAdmin so I could clean up additional fields that the tool didn’t find. 6) Edited .htaccess and wp-config to reference the new URL and database credentials. It worked.

    I’m going to close this out, but I’m leaving all this information here in case anyone finds themselves in this situation. Thanks, everyone, for your help. You led me in the right direction, and I appreciate it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problem migrating Multisite’ is closed to new replies.