WordPress.org

Support

Support » How-To and Troubleshooting » [Problem] How to disable enclosure

[Problem] How to disable enclosure

  • I use WordPress for quite some time now , and it is the first time I have noticed this feature.
    I hade made a “click here” link to an MMS stream (.asf) and i was surprised to see that on my custom fields area in my template, there was a new key called “enclosure” and the value of the link I have supplied.
    I searched a bit and read the forums , but found no way of disable it …
    I can not delete the key in the custome fields , or update to another value, because it automatically pops back.
    I can understand the value of it for podcasting, but not the fact that there is NO WAY to disable it .
    I do not want this key/value to show in my template, and for sure not in my RSS feed (this is not MY video or podcast, it’s just a link..)
    anybody knows how to go around it ? (except creating an empty HTML file with refresh value)

Viewing 9 replies - 1 through 9 (of 9 total)
  • Did you find a solution? I’m running into the same problem.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    If you turn off all ping sending services, this will disable it from finding enclosures as well.

    Add this to your theme’s functions.php file:
    remove_action('do_pings', 'do_all_pings', 10, 1);

    “If you turn off all ping sending services, this will disable it from finding enclosures as well.”

    Are there any adverse side effects to turning off pings?

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Err… Well, pings won’t work afterwards. 😀

    Other than that, not really.

    Yeah I kind of figured that, but what exactly does that mean? So pingbacks won’t work? or my listing on Technocrati (or other aggregators) won’t update when I publish my blog? Would my RSS file still update, just without the enclosures?

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    So pingbacks won’t work? or my listing on Technocrati (or other aggregators) won’t update when I publish my blog? Would my RSS file still update, just without the enclosures?

    Outgoing pingbacks stop working. Service pings (like to pingomatic) stop. RSS file continues working as normal, but without enclosures.

    First, I appreciate all your help.

    Outgoing pingbacks stop working. Service pings (like to pingomatic) stop.

    That seems pretty problematic. There’s no other way to turn this feature off?

    I’m using WP to run a podcast, we frequently have related audio/video features we want to include and linking to them is creating multiple enclosures in each post, which of course is a big no-no. It makes the podcast break in iTunes.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    There’s no other way to turn this feature off?

    Edit the core code to remove it. That’s the only other way.

    And enclosures are the only thing that make podcasts actually work. If you disable enclosures, then you suddenly don’t have a podcast.

    My advice would be to not link to things that are audio or video except for your podcast files. At least, don’t link to them directly. Link to a page with them on it or something else that doesn’t return the audio or video MIME type.

    Alternately, use podPress. I think it prevents the multiple enclosure problem.

    I’m having the same issue. I’ve got a flash audio player that plays music for local bands, but when people subscribe to the feed, they can download the song for free.

    I’ve asked feedburner for help, but got no answer after 10 days.

    I finally went to the plugin page, and it says to delete the enclosure from custom fields every time you update the post.

    Seems to be working for me, hope it helps. It is, however a pain in the butt.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Problem] How to disable enclosure’ is closed to new replies.
Skip to toolbar