Support » Plugin: Nooz » Press coverage not showing – code not in page source

  • Resolved jerepowers

    (@jerepowers)


    Using Elegant Themese Divi theme.

    I have the press release part working fine.

    But for press coverage I get nothing. The sample code shown under Press Release Output does not appear on the page.

    Nooz created the pages.

    But I don’t have news section.

    The url of the page is about-us/press-coverage

    Under settings for press coverage I also have it as about-us/press-coverage

    I tried adding news to the permalink, but it removes the slash (/)

    So it may be looking for about-us/news/press-coverage but that page doesn’t exist.

    https://wordpress.org/plugins/nooz/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor farinspace

    (@farinspace)

    Go to Settings > Permalinks and click “Save Changes” .. this will flush the rewrite rules, see if that has any effect.

    No change.

    Does this use a different template than releases? Could it be corrupt?

    Plugin Contributor farinspace

    (@farinspace)

    I can troubleshoot and have a look, if you would like .. support at mightydigital dot com

    Plugin Contributor farinspace

    (@farinspace)

    After having a look and troubleshooting: Everything is OK with the plugin, it is working as expected. The issue was with a custom filter in your functions.php

    You appear to be using the “nooz_shortcode” filter with a custom php/html template. The template was setup to only handle a flat list of items, however when the list is set to “group”, the template should be modified accordingly along with the data structure. I have made a few notes in your functions.php file and for now disabled the filter.

    You can let Nooz output the content for you and simply style it with CSS or you can make PHP adjustments to your custom template file (based off of the data structure).

    I am having the same problem. I insert the [nooz] shortcode on a page and it only displays press releases but no press coverage. There are no filters setup for the nooz_shortcode. The site was built on jointsWP.

    Plugin Contributor farinspace

    (@farinspace)

    Ideally, Nooz was able to create default pages during installation, I would recommend that you inspect those page to see the shortcodes that Nooz creates. Additionally have a look at the help tab for Nooz (upper right corner).

    Here are the relevant shortcodes:

    [nooz] (will default to press release)
    [nooz type=”release”]
    [nooz type=”coverage”]

    Okay thanks – I was wondering about shortcode params. Is there a way to specify both release and coverage in the shortcode?

    Plugin Contributor farinspace

    (@farinspace)

    Not through the shortcode attributes, however if you are an advanced user, you could use a filter:

    function my_query_options( $options ) {
        // you could use $options['post_type'] to target specific shortcode usage
        // [nooz type="custom"]
        // if ( 'custom' == $options['post_type'] ) { ... }
        $options['post_type'] = array( 'nooz_release', 'nooz_coverage' );
        return $options;
    }
    add_filter( 'nooz_shortcode_query_options', 'my_query_options' );
    

    Perfect! Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Press coverage not showing – code not in page source’ is closed to new replies.