• Resolved Will Stocks

    (@willstockstech)


    I’ve just moved over from WP Super Cache and wondered whether it’s possible in any way to “preload” the cache in a similar fashion? At the mo, the cache only seems to be generated after first page visit

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @willstockstech,

    Unfortunately, at the moment, there is no cache preloading. But this is a feature on our to-do list. Should be available in the near future.

    Best regards,
    Anton

    Will Stocks

    (@willstockstech)

    Cheers @vanyukov

    Is it the same for both page cache and optimized assets? I set a bunch of assets to combine, but they all still seemed to load separately on page views, so I’ve re-enabled autoptimize and deactivated asset optimization where my assets are all now combined as autoptimize files

    Will Stocks

    (@willstockstech)

    So I just had another look… it seemed to be serving me the hummingbird assets combined, but only for logged on users (i.e. me as an admin). Publically though, the assets were still all separate (although since deactivating asset optimization and reactivating autoptimize, they’re all now combined).
    Any ideas?

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @willstockstech,

    Should be same for all the users. Will test it out, but no one has ever reported such behavior. Also, Hummingbird will respect the order of files in WordPress, so if two files can’t be combined for any reason (for example, one should not be shown in Internet Explorer), Hummingbird will not combine such files. This is done so your site does not break in certain situations. Also when it comes to the combine function, I would really recommend going the HTTP/2 route, as this is a far better option.

    Best regards,
    Anton

    Will Stocks

    (@willstockstech)

    “I would really recommend going the HTTP/2 route, as this is a far better option” – as in leave the files all separated out, simply optimized?

    When I did combine files, I had to “move to footer” my child theme css as it wasn’t “overriding” my parent theme CSS as I expected (moving to footer worked). Do I need to fully disable and deactivate plugins such as autoptimize?

    I don’t know if you need any info from me to investigate that one at all? High level:
    PHP 7.2.8
    WP 4.9.8
    Hummingbird 1.9.2

    Plugin Author Anton Vanyukov

    (@vanyukov)

    as in leave the files all separated out, simply optimized?

    Yes

    Do I need to fully disable and deactivate plugins such as autoptimize?

    You should not be enabling similar functionality in different plugins, as that can cause issues. So if you’re optimizing file in Hummingbird, do not do the same in Autoptimize and vice versa.

    Best regards,
    Anton

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Preload cache?’ is closed to new replies.