Support » Plugin: Cf7 UI slider » Prefix Problem

  • Hi There,
    Love your Plugin. Very helpful.
    I tried to add pound sign(£) as prefix, after I added it didn’t show the sliders, It only works with $ sign.
    Is there any other way to do this?

    Thank You.

    • This topic was modified 4 years, 2 months ago by janakasajith.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author A.malakar

    (@ayushmalakar)

    Hi @janakasajith

    Thank you for your question. For now I can only give you a quick fix, I hope your comfortable with editing the files, as this is the only solution I can give you for now, I will make sure to address this issue in the future updates.

    What you are required to do is on the file wp-content/plugins/cf7-ui-slider/includes/slider-tag.php and wp-content/plugins/cf7-ui-slider/includes/range-slider-tag.php

    Please add the following line of code after line number 69

    if ( preg_match( "/&/", $atts['prefix'] ) ) {
    				$atts['prefix'] = html_entity_decode( $atts['prefix'] . ';' );
    			}

    And now in the prefix you can add the “pound symbol” simply by typing &pound

    Here is an example code
    [cf7_ui_slider cf7_ui_slider-3 id:test min:0 ui_default:8 max:77 prefix:&pound step:3]

    Please do let me know if this works for you or not

    Plugin Author A.malakar

    (@ayushmalakar)

    Hi @janakasajith

    Thank you for your question. For now I can only give you a quick fix, I hope your comfortable with editing the files, as this is the only solution I can give you for now, I will make sure to address this issue in the future updates.

    What you are required to do is on the file wp-content/plugins/cf7-ui-slider/includes/slider-tag.php and wp-content/plugins/cf7-ui-slider/includes/range-slider-tag.php

    Please add the following line of code after line number 69

    if ( preg_match( "/&/", $atts['prefix'] ) ) {
    				$atts['prefix'] = html_entity_decode( $atts['prefix'] . ';' );
    			}

    And now in the prefix you can add the “pound symbol” simply by typing &pound

    Here is an example code
    [cf7_ui_slider cf7_ui_slider-3 id:test min:0 ui_default:8 max:77 prefix:&pound step:3]

    Please do let me know if this works for you or not

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Prefix Problem’ is closed to new replies.