WordPress.org

Support

Support » How-To and Troubleshooting » Posts display backwards by date (oldest first)

Posts display backwards by date (oldest first)

  • I just upgraded to 3.3.1 and the posts on the home page are now not displaying properly. They seem to be ordering themselves backwards by date so that the oldest ones are displaying first. I don’t see any way to change this on the reading settings page or any other settings.

    Also, I don’t think the reading settings are working correctly anyway because when I change the number of posts to display or the summary vs. full, neither of those changes take effect.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator justingreerbbi

    @justingreerbbi

    Forum Moderator

    ????? you may have to add some code in the loop to sort by date and ASC

    The code in all the template pages was not changed so it should all be the same as it was before. The only thing different is that I upgraded the wordpress software to 3.3.1.

    Moderator justingreerbbi

    @justingreerbbi

    Forum Moderator

    This is what I am saying.. I do not know for sure but maybe in the upgrade version WordPress changed it queries around a bit.. I don’t know, I have not looked into it but this is why plugins and themes should be updated as well because things like this happen.

    The theme and all the plugins are updated. I also deactivated all the plugins to see if that made a difference. Do you know where in the code that sorting method would be? index.php under Themes > Editor? I glanced through that code and don’t see anything that is standing out, but there is a LOT of code in there. 🙂

    Can you give me a code segment and tell me where to put it that would tell the index.php page to sort posts by date? That’s the only page that isn’t working correctly.

    It appears to be sorting by post ID and not date because when I change the post date, it doesn’t change the display order. The template is London Creative.

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    I did try deactivating all the plugins and that made no difference.
    When I changed it to Twenty Eleven, it displayed correctly, so it does seem to be theme-specific.

    esmi

    @esmi

    Forum Moderator

    As London Creative is a commercial theme, you need take this up with the theme’s vendors.
    http://themeforest.net/forums/topic/themeforest/themeforest

    OK, thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Posts display backwards by date (oldest first)’ is closed to new replies.
Skip to toolbar