WordPress.org

Support

Support » How-To and Troubleshooting » Posting Drafts

Posting Drafts

  • DarkCryst
    Member

    @darkcryst

    Ok, I’m using the latest nightly built, and perhaps I’m being a dolt here…. but:
    When editing a post it turns it inot a draft, not wanted behavior reallly, but ok… however – there is no way of publishing the post again, it is removed totally and there is no way of getting it to display – no matter what you do to it.
    This happens if you make a draft too, it just seems drafts are rather broken. This wouldn’t be so much of a problem if it didn’t turn edited posts into drafts….
    Anyone have any clue how I can fix this? Or is it a known issue and I’m being dim?

Viewing 15 replies - 1 through 15 (of 15 total)
  • timeistight
    Member

    @timeistight

    I went into the database with phpMyAdmin and changed the post_status field from “draft” to “publish”.

    DarkCryst
    Member

    @darkcryst

    ick.. so it IS a known issue huh? Or is this just a bug with this latest build?
    So far this is the only issue I’ve had with the build I may add… except I have no idea how to add themes as there is no example theme, or how to add themes into the “theme” directory (of which there is none, I had to add it manually – an example demo theme would make sense for release – maybe implement the “kubrik” style that way… or make the default the example).

    Anonymous

    also, got this error message from posts, pages in Manage area.

    Warning: join(): Bad arguments. in /yourhomedirecory/wordpress/wp-admin/edit.php on line 13
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘)’ at line 1]
    SELECT ID, post_title FROM wp_posts WHERE post_status = ‘draft’ AND post_author IN ()

    gregsbaby64
    Member

    @gregsbaby64

    DarkCryst, are you talking about styles when you say themes? Check out my WP style switcher tutorial. 🙂

    bronski
    Member

    @bronski

    it seems there is a syntax error in line 13 of edit.php
    correct is $editable = join(',', $editable);
    instead of the wrong $editable = join($editable, ',');
    but that doesn’t bring the missing publish-button back… 🙁

    timeistight
    Member

    @timeistight

    > so it IS a known issue huh? Or is this just a bug with this latest build?
    Seems to be a bug with the last two nightlies:
    http://mosquito.wordpress.org/bug_view_page.php?bug_id=0000283

    timeistight
    Member

    @timeistight

    bronski, I made your edit to edit.php and I still get the database error.

    bronski
    Member

    @bronski

    just found out about that too, bummer. 🙁
    looking at http://www.php.net/manual/en/function.implode.php i was so sure about that…

    bronski
    Member

    @bronski

    i think this only happens when you have only one user.
    well, in edit.php in line 12 there is an SQL statement:
    $editable = $wpdb->get_col("SELECT ID FROM $wpdb->users WHERE user_level <= '$user_level' AND ID != $user_ID");
    so when there is only the admin-user, ID = 1, this select results in an empty quere, the array cannot be joined and the known error occurs.
    as soon as you add a second user the array contains values and the error is gone.

    DarkCryst
    Member

    @darkcryst

    as far as themes vs styles… no I was talking about the built in theme switcher 1.3 has, not a stylesheet switcher as your code seems to do (I know how to do that).
    Mostly I just wanted to know what files and where to drop them for the theme so I get a description. I could just edit the existing one, but I’d like to have it as a seperate theme, code and all.
    So yeah, not styles, themes 🙂
    The “new user can publish” thing could solve my problem..
    *checks*
    yup! that solved it! 🙂 Thanks to Bronski for that, so simple.. yet easy to miss at the same time. Hopefully this topic my provide some help to others…

    bronski
    Member

    @bronski

    well, with this patch applied the setting mentioned above doesn’t need to be set to “new users may publish” – great! thanks.

    DarkCryst
    Member

    @darkcryst

    well I think, to reuse a phrase… its not a bug, its a feature.
    The new user things makes sense, but really the default should be that they CAN publish, not that they can’t… its not really wanted behavior otherwise.

    Beel
    Member

    @beel

    There is a bug in there, though, as I (admin) am not a new user and have a user_level of 10 but only get the option of “draft” and “private” – unless I am missing something.

    Anonymous

    The patch fixed the SQL syntax error message but still no “Publish” radio button here either. I’m using latest 9-15-04 nightly.

    ivari
    Member

    @ivari

    same error
    PUBLISH BUTTON GONE
    and everytime edit post my post send to DRAFT.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Posting Drafts’ is closed to new replies.