Support » Fixing WordPress » Post – title links broken

  • Resolved webkiwi

    (@webkiwi)


    Just installed WP3 a few days ago, and made approx 20 posts, before noticing that when I click on the post topic/title, and try follow the link to the page that contains that single posts – its broken.
    Heres my current blog – http://www.dubdot.co.nz/blog/ – and click any of the post topics, and they return a 404 Not Found error.
    Is it something to do with my Categories, or is the url being corrupted somehow?

Viewing 14 replies - 1 through 14 (of 14 total)
  • More information on this – I am using Month/Day for Permalinks, I did this as part of the setup when I was installing. Just ftp’d onto my blog directory and I don’t see any .htaccess file. Would this be the cause of my link issue?

    OK, so investigations have revealed this seems to be when I have the Permalinks switched on – set to Month and Name.
    When I set it back to default – it works fine, all of my posts are linked correctly, the titles of the posts link and take the viewer through to a single page, featuring that particular post.
    Now – question becomes – WHY? WHats the matter with the Permalinks? Is it a known issue?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Can you verify with your hosting provider that mod_rewrite is configured properly on your server?

    I have been informed that mod_rewrite is correctly installed on the server, so it would seem its just the .htaccess file I am using – is this correct? Is there a barebones one that will suit my needs?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try re-saving your permalink structure at Settings/Permalinks in your admin panel. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.

    Thanks Mac, tried that, but still not working – 404 error still.
    This is the data from the wp_options table in my database, for the permalink structure: /index.php/%year%/%monthnum%/%postname%/

    Seems like it should work, but it just loses the index.php page when it tries to resolve the title link.

    Any other tips?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Does it work if you use the default permalink structure?

    Yes, the default setting is working:
    http://www.dubdot.co.nz/blog/?p=103

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    So, it seems like it’s definitely either a .htaccess or mod_rewrite issue.

    Try re-saving your permalink structure at Settings/Permalinks in your admin panel. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.

    When you’re done, can you share the contents of the .htaccess file here?

    Just re-saved the default settings, and refreshed the ftp connection, seems the .htaccess file is not changing date/time stamp, so not even sure it is being written to? Isn’t the details of the permalink structure set in the database?

    Anyway, contents of the file here:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Temporarily set the permissions of the .htaccess file to 666 and try again.

    OK, so the issue may well be the fact this is on a windows server, and using ISAPI rewrite on IIS. This changes everything considerably I assume? A quick fix for this environment?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    You said earlier, that according to your hosting provider, “mod_rewrite is correctly installed on the server.” If you’re on a IIS server, you won’t have mod_rewrite. Follow this guide:

    http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

    Thanks Mac, have switched host, now on linux, and all is fine. Couldnt be bothered with the hassles. Sincerely appreciate your time to assist.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Post – title links broken’ is closed to new replies.