WordPress.org

Support

Support » Plugins and Hacks » Subscribe2 » [Resolved] Post Problem

[Resolved] Post Problem

  • Greetings,

    I have a weird problem on my site using subscribe2 plugin.
    when i click the submit button the page just reloads doing nothing..
    i traced the issue on firebug and noticed the the post is sending only the ip and the email variables, and ignoring the subscribe or unsubscribe variables.

    on my friend host i noticed that the post variables are ip, email and subscribe
    ip=77.42.198.111&email=RandomEmail%40hotmail.com&subscribe=Subscribe

    on my host
    ip=77.42.198.111&email=RandomEmail%40hotmail.com

    notice what’s missing?

    I tried to trace what is going on, but i have little knowledge in php, i’m more into .net and action scripting.

    can anyone help me please, i don’t know if it’s a server problem or what, i contacted go daddy and the response wasn’t that useful.

    note that i stoped all plugins when i was tracing the problem.
    my link it wellnessawareness.info

    http://wordpress.org/extend/plugins/subscribe2/

Viewing 3 replies - 1 through 3 (of 3 total)
  • @hl78,

    Even though this is raised because of Subscribe2 you are asking in the wrong forum as this issue comes from your server configuration.

    From a little Googling it may be down to a ‘max_input_vars’ value in your php.ini file either not being set or set too low.

    Either way I think you should pursue this with GoDaddy, after all you are paying them money and what they are providing isn’t working right.

    thank you for the reply, i contacted godaddy, and since i’m using windows hosting they say there is no php.ini file, so inorder to do any change, i need to create a custom php5.ini since i’m using iis7.

    i searched the internet for a php.ini file but couldn’t find ‘max_input_vars’ so i added it and recycled the iis to make my changes work. to test i added a phpinfo.php file with a code <? phpinfo(); ?> i noticed that ‘max_input_vars’ is not there.
    link: http://wellnessawareness.info/phpinfo.php

    I’m sorry to bother you but is there any special setting for form submitting that should be done to the php5.ini file?

    I’m getting to a dead end!
    thank you for any help.

    @hl78,

    I really don’t know, I host on linux and it works for me.

    This PHP bug thread may contain something that might help you as it seems related:
    https://bugs.php.net/bug.php?id=22427

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Post Problem’ is closed to new replies.
Skip to toolbar