Support » Plugin: Slimstat Analytics » Possible incompatibility with PHP 7.0

  • Resolved Saša

    (@stodorovic)


    I don’t see that’s reported. I’m checking websites from time to time with php compatibility checker (and with other similar tools). I just saw possible error:

    wp-content/plugins/wp-slimstat/admin/update-checker/vendor/Parsedown.php
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     1412 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    

    It seems that external library Parsedown.php is outdated. It’s fixed by PR – https://github.com/erusev/parsedown/pull/302. So, it’ll be good to you update this library to avoid possible incompatibilities.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Our preliminary tests of the new library with our repository management system did highlight some issues, that’s why we haven’t updated it in a while. It’s on our to-do list though 🙂

    Best,
    Jason

    Plugin Author Jason Crouse

    (@coolmann)

    Would you like to test the next update to see if it solves the problem you were experiencing? If so, please contact us at http://support.wp-slimstat.com to get in touch!

    Best,
    Jason

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Possible incompatibility with PHP 7.0’ is closed to new replies.