Support » Plugin: TinyMCE Custom Styles » WORKING FINALLY

  • Styles were never called.
    But I am changing the review to 5 stars because the author helped me to go thru the problems until they were solved.

    • This topic was modified 9 months, 3 weeks ago by HairyPotter.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Tim Reeves

    (@tim-reeves)

    Hi @hairypotter ,
    well I’m really surprised at your comment, which I find uncharitable and incorrect. Just look at the plugin landing page and you’ll see that I’ve written much more than almost any other plugin offers, even including the history of the plugin and how to put it to work together with Advanced Editor Styles. I have it installed and working fine on a lot of sites (so it seems have about 8.000 others), including with Gutenberg. If you have a specific problem then please ask for support before complaining.
    That said, I can’t guarantee quick support as I’m so busy in these turbulent times, but a few minutes may be possible to clear up any misunderstandings.
    Hoping this helps,
    Tim

    P.S. I’m 67 and sliding slowly into retirement, and would be most glad if someone else would take over responsibility for the plugin.

    Thread Starter HairyPotter

    (@hairypotter)

    Hi, thanks for your message.

    For example, I have this code on a page

    <p class=”abc”>HELLO WORLD</p>

    and this css

    .abc {
      font-style: italic;
        color:#444;
        line-height: 1.6;
        letter-spacing:1px;
        font-family: 'Fuzzy Bubbles', cursive;
        font-family: 'Open Sans Condensed', sans-serif;
        font-family: 'Shadows Into Light', cursive;
        font-size: 1.2em;
      }

    on both editor-style.css and editor-style-shared.css.

    Styles are not applied anywhere.

    I have tried

    p.abc { // bla bla }

    and nothing

    If I do

    p {
      font-style: italic;
        color:#444;
        line-height: 1.6;
        letter-spacing:1px;
        font-family: 'Fuzzy Bubbles', cursive;
        font-family: 'Open Sans Condensed', sans-serif;
        font-family: 'Shadows Into Light', cursive;
        font-size: 1.2em;
      }

    then it applies the style to all paragraphs.

    • This reply was modified 9 months, 3 weeks ago by HairyPotter.
    Plugin Author Tim Reeves

    (@tim-reeves)

    First of all, you only need to put a style in editor-style-shared.css for it be available both in the frontend (web page) and the backend editor.

    If it’s not working then you probably have a problem with your setting for having it included. This must be

    a) selected on the settings page of the plugin, at “1. Enhance the visual style of your TinyMCE”. Personally I always select the 3rd option and use an extra directory “uploads/styles/”, which seems the cleanest way.

    and b) you have to upload your locally edited files via FTP to the exact location you specify in the settings, and without changing the file names, these are fixed in the code.

    And then, it really should work. I haven’t heard of any problems in this area. If there are problems it will normally be with a bug in Advanced Editor Tools plugin which overwrites entries in the “Formats” dropdown of TinyMCE, but that’s a different topic.

    Thread Starter HairyPotter

    (@hairypotter)

    I have tried what you suggested. Problem continues.

    Thread Starter HairyPotter

    (@hairypotter)

    This is how I have created the style

    https://ibb.co/vkH48Gq

    Plugin Author Tim Reeves

    (@tim-reeves)

    Well, that’s not how you create a style; that’s how you create an entry for the “Formats” dropdown of TinyMCE (btw. try without “Exact”)

    Those entries only allow you to work more conveniently with TinyMCE (unless you define inline styles – not recommended), and can be used for any styles which are available in the frontend, e.g. from the theme or another plugin.

    CSS entries here are effectively a convenience to save you having to switch to the text tab of TinyMCE and adding the class manually to the HTML.

    Please check out the section above in the settings, about how to specify, edit and upload your styles.

    You can see if a stylesheet is being loaded by using the browser debugger (ctrl shift i in FF / Chrome) and there the Network tab.

    Thread Starter HairyPotter

    (@hairypotter)

    Thanks for your answer.

    Network shows the plugin style is not being loaded. I can force the frontend style by loading it on header. Is there a way to do the same for the editor?

    Plugin Author Tim Reeves

    (@tim-reeves)

    Do you mean it’s being requested but not found, or not requested at all? If the former, then that would mean that the stylesheet file is not where you’ve told the plugin that it is. If the latter, then for some reason my Plugin is failing to enqueue it’s stylesheet, or another instance is wiping it from the queue. This may happen if something in the Theme or another Plugin is messing around with the list of enqueued styles. I’m certain that my plugin follows the correct WordPress procedure. In which case, you’re on your own, I can’t provide unpaid support at that level. You can try switching to a standard theme such as 2020, or turning off all other plugins (it should wokr then) and switching them bak on one by one until you find the culprit.

    Thread Starter HairyPotter

    (@hairypotter)

    Not requested at all. Oh yeah both CSS are where I told the plugin.

    That installation of wordpress is brand new. I have installed it a couple of days ago for testing purposes only, not to work on the production site. The theme it is using is basically the 2021 slightly modified. I have just 3 plugins installed: yours, classic editor and Advanced editor Tools (previously TinyMCE Advanced).

    I have switched to regular 2021 theme and the problem persists.

    I have reinstalled wordpress and now your plugin is loading the shared css but the problem persists.

    thanks for the support given.

    • This reply was modified 9 months, 3 weeks ago by HairyPotter.
    • This reply was modified 9 months, 3 weeks ago by HairyPotter.
    • This reply was modified 9 months, 3 weeks ago by HairyPotter.
    Plugin Author Tim Reeves

    (@tim-reeves)

    Yeah that’s beginning to look really strange. Have you tried deactivating the other two plugins? In particular AET is known to mess about with things a bit…

    Thread Starter HairyPotter

    (@hairypotter)

    I have finally discovered the problem. For some reason, the shared css file was being created using some wrong encoding. I discover that when I saw the file from terminal. I created a new shared file using VI and everything worked fine. Thanks.

    Plugin Author Tim Reeves

    (@tim-reeves)

    Great to hear it’s solved. Would appreciate an improved ranking…

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘WORKING FINALLY’ is closed to new replies.