Support » Fixing WordPress » Plugins page and Dashboard broken

  • While debugging a plugin, I had deactivated all my plugins and when reactivating them, suddenly the plugins page broke.

    Now the plugins page times out (The page cannot be displayed) and the Dashboard doesn’t load completely.

    I have tried this on different internet connections and PCs and browsers but the problem is consistent across all.

    Please help, I really need to get this working.

    The plugin-editor page works fine as well as other pages.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator James Huff

    (@macmanx)

    Try deleting the plugin files (save them as a backup to another location first).

    Hey it worked, now what do I do?

    But dashboard still doesn’t load

    I deleted the entire folder and created a new plugins folder and it worked fine.

    The moment I add any plugin into this new plugins folder it throws up the page cannot be displayed for the plugins page

    Moderator James Huff

    (@macmanx)

    Make sure that the plugins folder is CHMOD 755 and all plugin therein CHMOD 666. Have you tried just inserting each plugin one-at-a-time?

    Plugins and its contents are chmoded to 777 as before.

    Haven’t changed any chmods so I don’t think that would be a trouble.

    I tried inserting one plugin at a time.

    Any idea how I reset WP so that it requires me to reactivate all plugins?

    Just did a database restore from before this problem.

    Now both the plugins page and the dashboard page load uptil the closing style tag of Spam Karma 2.

    From the other pages I find that immediately after the </style> is the </head>

    Any suggestions other than a fresh install?

    Just did a fresh install with fresh files and deleting the database.

    Plugins work now perfectly, however my dash doesn’t seem to fetch the RSS.

    Running 1.5.1.3

    Moderator James Huff

    (@macmanx)

    however my dash doesn’t seem to fetch the RSS.

    That’s a common hosting problem. Usually, hosts only allow certain feeds to be pulled through their firewall via the methods that WP uses.

    I dont think this is the problem for two reasons.

    1. It was working before the blog broke and had to do the fresh install

    2. Another blog running same version of WP on the same server fetches the RSS properly.

    Do you really care for the feeds?
    If yes, why not subscribe to them using your RSS reader?

    If no, why not use my Dashboard hack? It is much faster than the default Admin Dashboard.

    Moderator James Huff

    (@macmanx)

    I dont think this is the problem for two reasons.

    1. It was working before the blog broke and had to do the fresh install

    2. Another blog running same version of WP on the same server fetches the RSS properly.

    Yes, but are the feeds on the working blog up to date? If your host implemented a security measure that blocks the feeds, an older blog will still show the feeds, but never update (because it has retrieved and cached them before the security measure was implemented), while a new blog will never show the feeds (because it cannot retrieve and cache them).

    As of now the last feed on the working blog is Matt: AARP

    It seems to be updating regularly.

    I have had recurrent similar problems with the Dashboard. I highly recommend Angsuman’s hack, and subscribing to the DevBlog with Bloglines! 🙂

    Nice hack angsuman.

    However, since I wanted the news feeds I followed the link from your page to Squeg’s hack

    Looks good now.

    Yes, it is there to assist people with feed needs 😉

    I am happy to know it finally worked for you.

    Personally I heavily use my new aggregator to read all kinds of feeds, well categorized and indexes.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Plugins page and Dashboard broken’ is closed to new replies.