WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WPBook] Checking permissions failed

[Resolved] [Plugin: WPBook] Checking permissions failed

  • Hello,

    Since the 2.5.2 upgrade of WPBook, I get this error :

    Your Facebook Access Token for WPBook has expired. Please visit the settings page for WPBook and grant a new access token. Until you do so, cross-posting to Facebook and import of comments will fail.

    I visited the settings page for WPBook but when I check permissions in Facebook I go to an error : in order to access this page you need to connect as yourself and not as facebook page (in english)

    I don’t understand. Can you help me

    Thanks

    http://wordpress.org/extend/plugins/wpbook/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author John Eckman

    @johneckman

    It means you are trying to grant permissions to the application *while using Facebook as a page*.

    You have to be *using Facebook as you* when you do the permissions granting as it requires your individual account to give permissions not the page

    Yes I understand but when I connect as myself, I get an error :
    An error has occurred. Please try again later.
    Why ?

    Plugin Author John Eckman

    @johneckman

    @spasmody In general this is a mis-configuration.

    What is the address of your WordPress blog outside Facebook? What do you have set as the domain of your app inside Facebook?

    Do you have your Facebook profile ID set correctly in the settings inside WPBook? Where it asks for your Facebook profile ID you cannot put a page ID or group ID – has to be an individual profile ID, and you have to be logged in as that profile ID when you go to check permissions.

    Do you have access to the PHP Error log on the server your blog is hosted on? Can you see if any errors are thrown there?

    John, it’s a bug in WPBook.
    I fixed fb error and now the fb application’s working fine.
    But that error keep displaying.
    You can fix the remanent error in 2.5.3 version
    Thank you

    Plugin Author John Eckman

    @johneckman

    @spasmody Happy to fix it as soon as you can tell me what the bug is.

    What is the error you’re saying remains?

    Your Facebook Access Token for WPBook has expired. Please visit the settings page for WPBook and grant a new access token. Until you do so, cross-posting to Facebook and import of comments will fail.

    Plugin Author John Eckman

    @johneckman

    @spasmody that’s not an error – it is a note to the admin and includes instructions for you, to generate a new access token.

    Have you done so?

    You need to first make sure your Facebook application, advanced settings, has “remove offline_access” set to ENABLED – then go to the checking permissions page and generate a new access token.

    yes John, it’s working now. No error anymore.
    Thank you

    Hello

    ive got the same Problem. Please can you help me?

    Plugin Author John Eckman

    @johneckman

    @dominikest Which problem do you have?

    Have you done what the error is telling you to do, as I asked spasmody above?

    So I’m getting the same notification but when I try to check permissions I get this response:
    ************************
    Secure Connection Failed

    An error occurred during a connection to http://www.richarddavisphotography.com.

    SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long)
    *************************
    Any idea on how I fix this?

    I’ve followed the other advice in this post and changed the advance settings as above. Where do i find what all the recommended settings should be. I gone back and forth through the setup docs but they seem outdated with regard to the screenshots. Am I missing something that steps through the choices on the Advanced Settings of the app?

    Do I need to blow away my old app and create a new one?

    Plugin Author John Eckman

    @johneckman

    @rdavisphoto This is a problem with your ssl setup on your server – not a WPBook issue.

    Just visiting https://www.richarddavisphotography.com/ throws:

    Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.

    In order for WPBook to work properly your blog must be accessibly via Https:// urls

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: WPBook] Checking permissions failed’ is closed to new replies.