Support » Plugins and Hacks » [Plugin: WP Post Thumnail]

[Plugin: WP Post Thumnail]

  • Hello,

    I’ve designed a theme for a client that uses WP Post Thumbnail but ran into a problem transferring it from my development environment to the server.

    For reference, the plugin <http://wordpress.org/extend/plugins/wp-post-thumbnail/&gt; uploads an image an allows you to decide what area of it will be used as a thumbnail for the front page.

    Every time I upload an image it tells me the upload was successful but doesn’t load the thumbnail editor, nor is the file uploaded to the directory.

    I think it has to do with permission but I’m not good enough at php to figure it out. Please help.

    Thank you

Viewing 15 replies - 1 through 15 (of 22 total)
  • Have you checked the CHMOD of the directories?

    I’m having the same exact problem as Itcanuck. And uploads folder is Chomd to 777. It says picture uploaded successfully. But no options to crop and uploads directory is empty. I uploaded the wppt.xml to default theme directory as well.

    Sorry for the question, are you talking about “Post-thumb/ Post-thumb revisited” plugin? can you post link to the plugin???

    Post Thumb or Post Thumb Revisited

    Im talking about WP Post Thumbnail

    I have the same problem. I just upgraded to 2.7 before installing.

    Same problem here, any chance this will be resolved in the near feature? I’m about to launch a new website in january and this is one of the plugins I really would love to use!

    btw. also using WP2.7

    I had the same problem after moving my WordPress installation from localhost to my real site.
    I fixed it by emptying wppt_general_options in the prefix_options table.

    Same probleme here (wp 2.7) but issue from Repsaj_Nav doesn’t work for me :'(

    I’m having this problem too. I’d like to:

    fixed it by emptying wppt_general_options in the prefix_options tabl

    as Repsaj_Nav suggested, but I can’t find the wppt_general_options. Or anything marked wppt, or anything that looks like it goes with this plugin. I’m assuming I could get to it using PHPMyAdmin, cracking open the database.

    What am I missing? i’d appreciate any specifics!

    Ah, the information I needed is on the developer’s blog, in the comments:

    “Paul” on a Jan 6 comment said:

    WP 2.7 working…

    I was able to get the plugin to work in WP 2.7 by deleting the wppt_* options directly from the database. That is to say:

    1.) Use something like “phpmyadmin” to connect directly to your database server.

    2.) Navigate to the database for your installation and find the “options” table.

    3.) That table has a hundred or so entries. You can just “Browse” through the table for the 2 or 3 that begin with “wppt_”[something]. Or (if you have thousands of entries) you could do a Search and put in “option_name like ‘wppt_%’” as your search criteria.

    4.) Delete those options that begin with “wppt_”.

    After I did this, the next time I tried to upload an image with wppt it worked just fine.

    [I noticed that even after disabling the plugin and re-enabling it, my wppt options in the database were still those from an earlier installation. My suspicion was that maybe WP changed the way it stores array data in going from WP 2.6 to 2.7? And that disabling the WPPT plugin apparently doesn’t erase the option arrays stored in the database? I don’t know… but this worked for me :->]

    I’ve tried all that been said above but no way, it doesn’t work. It works fine in localhost but not after moving to the server. Did you find a solution?

    This plugin worked fine for me on 2.7, and now it suddenly doesn’t. I don’t think the developer is still working on it though so might be worth giving up and jumping to something else. 🙁

    What are we going to jump to?

    Psot-thumb is crap, and this plugin is crap. You’d think given the popularity of WordPress that these so called “plugin developers” would design something that works. We can’t even hack the code to correct it…..if you find something that works post back. I’ll do the same.


    how about coding it yourself then, doctorcilantro.
    plenty of “post attachment” or “post image” functions being displayed here.

    You could also pay one of these so called plugin developers to create something specially for you, instead of releasing “general” crap that does not work on your setup.

    it’s strange because the plugin working good on wp 2.7 without any modify.

    do you have add the file wppt.xml in the theme folder ?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: WP Post Thumnail]’ is closed to new replies.