WordPress.org

Support

Support » Plugins and Hacks » WP-Piwik » [Resolved] [Plugin: WP-Piwik] Graphs/Charts Not Appearing

[Resolved] [Plugin: WP-Piwik] Graphs/Charts Not Appearing

  • Hi,

    I’ve set up a Piwik server, and I’ve installed wp-piwik on a multisite installation. The statistics appear for the various sites, but the graphs/charts do not appear.

    Is there an additional installation step necessary to make them appear? I assumed that the appropriate components were also included in the plugin. If not, how do I install them in a WordPress multisite installation?

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author braekling

    @braekling

    Hi,

    WP-Piwik contains everything you need (except Piwik itself, of course). Maybe there wasn’t just enough data to create a graph?

    You also have to enable JavaScript, because the charts are created by jQuery.

    Hi,

    Thanks for the reply.

    Maybe there wasn’t just enough data to create a graph?

    I don’t think so. Even with no data, I believe that the graph background should appear? (The axes, numbers, grid, etc.) Right? But there is just empty white space.

    Interestingly, if I install as a regular plugin and network activate, the graph components do appear. But I need to set it up following the MU method so users do not have to enter their own codes.

    Any help will be greatly appreciated. 🙂

    Mark

    Plugin Author braekling

    @braekling

    Hm, ok, maybe jQuery or parts of jQuery are not loaded. Perhaps the loader-functions differ between WP and WPMU. I’ll have a look at this tomorrow and I’ll tell you about my results.

    Thank you!

    BTW, in WPMU mode I did not see all of the settings, for example the permissions control (who is able to see reports), and the control for adding Piwik to the WP Dashboard. This behavior is normal, right? I mean in WPMU mode the plugin should not display as many settings as in WP mode, right?

    Thanks.

    Two other questions:

    1. In the stats page (where I’ve been seeing the graphs not appearing), the “collapse” buttons in the modules do not work. Clicking the arrow in the top right of each module does not collapse or expand that module, as it does elsewhere in the Dashboard.
    2. Also, in WPMU mode is there a way to enable the Dashboard display of stats for the various users in their sites?

    Thank you.

    Plugin Author braekling

    @braekling

    WP”MU”-Piwik does not support all features supported by WP-Piwik. As described, the WPMU support is currently experimental, so please be patient to get all features in WP”MU”-Piwik.

    The collapse-bug may be caused by the same bug causing the plot-bug.

    Just one more question: Are you using classic “WPMU” (2.x) or the up-to-date WordPress Multisite function (3.x)?
    http://codex.wordpress.org/Create_A_Network

    Hi,

    I am using WordPress 3.0.1 multisite.

    No problem about the features…but I do hope to see the plot-bug fixed. 🙂

    Thanks again for your help.

    Best regards,

    Mark

    Hello Again,

    I am wondering if you have been able to make any progress on the issue with the charts not appearing.

    I’m not trying to rush you, I am just curious. I am eager for my WPMU users to enjoy the benefits of Piwik. 😉

    Thanks,

    Mark

    Plugin Author braekling

    @braekling

    Don’t worry, there will be a fix very soon. I think I got it 🙂

    Thank you!!! That is great news!

    Mark

    Plugin Author braekling

    @braekling

    Did you try 0.8.1? It should work now 😉

    Will try shortly. Thank you for addressing this!

    Yes, the fix worked! Thank you very much. This is an excellent plugin!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: WP-Piwik] Graphs/Charts Not Appearing’ is closed to new replies.
Skip to toolbar