WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [Plugin: WordPress Stats] Error after update to 2.6

[Resolved] [Plugin: WordPress Stats] Error after update to 2.6

  • After upgrading to 2.6 and activating the WordPress Stats plugin I get a message that WordPress Stats needs an API key. So I go to the settings, put it in, and when I try to save the settings I get this message (some info stripped):

    Warning: require_once(***/wp-includes/class-IXR.php) [function.require-once]: failed to open stream: No such file or directory in ***/wp-content/plugins/stats.php on line 344

    Fatal error: require_once() [function.require]: Failed opening required ‘***/wp-includes/class-IXR.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /***/wp-content/plugins/stats.php on line 344

    I checked. All the files are there – obviously because I was able to activate the plugin and to go to the settings. class-IXR.php file is all in smallcaps on my server, but I think thats not a problem.

    Any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • anyone?

    Ok. for anyone who has the same problem… It was a small caps issue after all. Seems like the files are linking to class-IXR.php, while the file on my sever was all small caps. I just changed it from class-ixr.php to class-IXR.php and it works.

    At least you are getting stats! Mine have been flatlined at 0.

    I don’t have statistics either… This plugin had been working great until i upgrated to 2.5, after that i’ve been stuck to 0.

    Anyone knows a workaround of this?

    I haven’t upgrade to 2.6 yet, but my statistics are not working either.

    So, has anyone found a solution for this bug?

    WHAT THE F?!?! I thought those guys would fix it by now. I just updated from 2.6 to 2.6.1 and now not only I get a message that WordPress Stats needs my attention, but when I enter my apikey it tells me that its not mine and that it belongs…. TO ME!!!

    What should I do? I really had enough of this!
    Anyone?

    I am on wordpress 2.7 and I am trying very hard to find a fix for:
    WordPress.com Stats needs attention: please enter an API key or disable the plugin.
    Error from last API Key attempt:

    Your blog was unable to connect to WordPress.com. Please ask your host for help. (transport error – HTTP status code was not 200)

    Please help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: WordPress Stats] Error after update to 2.6’ is closed to new replies.
Skip to toolbar