WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WordPress SEO by Yoast] Auto-Sitemap Error

[Resolved] [Plugin: WordPress SEO by Yoast] Auto-Sitemap Error

  • When enabling the sitemap functionality – my sitemap.xml file always gives this error:

    This page contains the following errors:
    error on line 1 at column 1: Document is empty
    Below is a rendering of the page up to the first error.

    Anyone know how to fix this as it is interfering with Google’s ability to be notified and indexability of the site?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Not sure if this was the issue, but I thought I’d share what I did and seemed to fix it.

    1. I upgraded to 3.1
    2. I determined it was an upload path problem – other WordPress SEO error displayed.
    3. Changed the settings for the Media (Settings>Media) to be blank [not specified].

    Hope this helps anyone else with this problem.

    I don’t have that setting under my Settings>Media menu. Any other suggestions to fixing this problem? I really need a sitemap!

    What WP version are you using?

    3.0. We don’t really want to upgrade at the moment as we have just got everything stabilized, site performance wise, but it seems strange that it wouldn’t work in 3.0!

    You should have that navigation on the left. Click on the arrow next to “Settings”, then click on “Media” and you’ll see what I was referring to.

    Good Luck!

    I don’s see it on my backend, if I could attach a screenshot I would!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: WordPress SEO by Yoast] Auto-Sitemap Error’ is closed to new replies.