WordPress.org

Support

Support » How-To and Troubleshooting » [Plugin: WordPress HTTPS (SSL)] Version 2.0.2 will not work with plugin simplemap

[Plugin: WordPress HTTPS (SSL)] Version 2.0.2 will not work with plugin simplemap

  • Version 1.9.2 works perfectly with Simplemap (Google maps), but when I update to 2.0.2 my website shows checkout and contact pages as partially secure. Disabling simplemap fixes this.

    Unfortunately this plugin will not load google maps if I make it page specific.

    What has changed in V2.0.2 so it longer forces SSL here?

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hey lesb55,

    A lot changed at 2.0, so it’s possible some changes it logic now prevent it from working. I’ll install SimpleMap and see if I can reproduce it.

    Thanks,
    Mike

    Hi Mike,

    Forgot to mention I also have this code loaded in my themes functions.php file:

    add_action( 'wp_print_scripts', 'my_deregister_javascript', 100 );
    
    function my_deregister_javascript() {
       if ( !is_page('Find a Dealer') ) {
    	wp_deregister_script( 'simplemap-google-api' );
         }
    }

    This works fine with Simplemap and WordPress HTTPS V 1.9.2,
    but not with V 2.0.2.

    Thanks for looking into the problem!

    Looked at the page in Google Chrome (as you suggest) and found what was causing the partial encrypted error.
    My functions.php file now looks like this:

    add_action( 'wp_print_scripts', 'my_deregister_javascript', 100 );
    
    function my_deregister_javascript() {
       if ( !is_page('Find a Dealer') ) {
    	wp_deregister_script( 'simplemap-google-api' );
    	wp_deregister_script( 'simplemap-master-js' );
         }
    }

    Hurray! fixed the error and simplemap still works OK

    Hey lesb55,

    That’s a pretty good idea. 🙂

    I’d like to add something to WordPress HTTPS that allows you to remove problem elements on secure pages automatically or by choice through some kind of interface.

    I’m still looking into why it may have worked in the previous version and not the latest.

    Thanks,
    Mike

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WordPress HTTPS (SSL)] Version 2.0.2 will not work with plugin simplemap’ is closed to new replies.
Skip to toolbar