WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WordPress HTTPS (SSL)] Redirect loop after upgrading

[Resolved] [Plugin: WordPress HTTPS (SSL)] Redirect loop after upgrading

Viewing 15 replies - 1 through 15 (of 17 total)
  • practicallydutch
    Member

    @practicallydutch

    Same issue here.

    Having the same issue. Any page with force SSL on will do endless redirects ending in error 310: Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects. in Chrome. Need this fixed soon! Everything was fine with version 3.0.3

    Same issue here

    I’m having the same issue as the others. I’m using a shared SSL an this is the secure path to my site: https://secure.netsolhost.com/035903d.netsolhost.com/wordpress1. The site pages will show but after activating the plugin wp-admin/edit.php is in an infinite redirect loop. I’m not using custom permalinks – I’m using the postname permalinks. I tried the fix you listed about uncommenting //define(‘WPHTTPS_RESET’, true); but it didn’t work. Any help would be appreciated.

    I reinstalled the older one – after deleting the newer version – you can download from…

    http://downloads.wordpress.org/plugin/wordpress-https.3.0.3.zip

    Keith
    Member

    @sononaco

    I also reinstalled the 3.0.3 version of the plugin which is working properly.

    Wendell Harness
    Participant

    @wendellh

    I tried that, and while I don’t get the 310 error in the admin area, it still occurs on SSL-enabled pages.

    paulroberts
    Member

    @paulroberts

    I’m getting a white page with “Unknown action” for all admin pages on a multi-site install with the plug-in active, the Network Admin page is unaffected.

    I’ve reverted to the 3.0.3 version

    monkseo
    Participant

    @monkseo

    I get the same problem with 3.0.3 and .4 when I select only force on pages with force enabled and when I goto the checkout page it goes to https then http and back and forth a bunch till the page crashes.

    jessemeyers
    Member

    @jessemeyers

    Installation details:
    Wordpress 3.3.2
    Plugins:
    WP e-Commerce 3.8.8.1
    Gold Cart for WP e-Commerce 2.9.7
    Twitter for WordPress 1.9.7
    Cimy Swift SMTP 2.1.3
    WordPress HTTPS 3.0.4

    Permalinks structure: /%category%/

    Issue: With WP e-Commerce, Gold Cart, and WordPress HTTPS plugins active I am unable to access certain pages in the admin panel, specifically Products, Dashboard, Media, Categories (under Products).

    If I disable Gold Cart and WP e-Commerce I am still unable to access Dashboard.

    Everything was working before updating to WordPress 3.3.2 but rolling back is not an option at this time.

    jessemeyers
    Member

    @jessemeyers

    Forgot to add that if I disable WordPress HTTPS then everything works fine except the Checkout page doesn’t show the Lock icon for customers which is kinda important. Thanks for all your help in making this plugin to begin with!!

    Diana Ross
    Member

    @drossbcccedu

    same issue here. For some reason, the loop is also preventing me from logging into my dashboard. I’ve emailed my tech-support guy to see if my website can be accessed at the server site.

    Diana Ross
    Member

    @drossbcccedu

    I managed to get into the dashboard after manually typing in the “https” version of the log-in address, deactivated/deleted the 3.0.4 and installed 3.0.3 from that link posted above (THANKYOU THANKYOU!) and all is working as intended.

    jessemeyers
    Member

    @jessemeyers

    Downgraded to 3.0.3 and issue persists.

    Downgraded to 2.0.4 and issue is resolved. I’ll wait to upgrade for now I guess.

    adamjsmith
    Member

    @adamjsmith

    Also had to downgrade due to the redirect loop, anyone here find a fix? (other than the downgrade!)

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] [Plugin: WordPress HTTPS (SSL)] Redirect loop after upgrading’ is closed to new replies.