WordPress.org

Support

Support » Plugins and Hacks » WordPress HTTPS (SSL) » [Resolved] [Plugin: WordPress HTTPS (SSL)] Permalink

[Resolved] [Plugin: WordPress HTTPS (SSL)] Permalink

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mike Ems

    @mvied

    Enable Force SSL Exclusively (development version) and you should get what you’re looking for. For the record, what you’re seeing in the admin panel isn’t the permalink. Either URL will work for the link, depending on your settings. It’s not one or the other unless you’re using Force SSL Exclusively.

    This is awesome! And I have to say thank you as it seems to work! I’ll let you know if I notice any bugs!

    I am not sure what you mean as for the record! When I was in the post editor before Enable Force SSL Exclusively, the slug definitely put my shared SSL address by default I.e.http://xxx.hostageprovide.com/%postname% (That might have been the point you just made, but not reassuring when you first try it!)

    But I have to admit I didn’t test it to see if that would the case (reflect) once published on the public side! (If you want me to test it I can).

    Now, I am not the most savyy guy out there 🙂 (maybe a good reason to make it idiot proof) 🙂

    But I initially assumed forcing for admin, would not compromise or influence my public side of the website (non admin side). http://mysite.com

    So maybe you can make it clear somewhere that you need both, forcing for admin (http://xxx.hostageprovide.com/) and Enable Force SSL Exclusively so that it works for your admin and doesn’t conflict with your public side! I hope you understand what I mean! In my own stupid world 🙂 Forcing for admin only concerns the admin side 🙂

    Now that I have done both (There is no confusion), when creating a post, the slug shows as http://mysite.com/%postname% (even tho my admin post edit URL is http://xxx.hostageprovide.com/wp-admin/post-new.php) so that it is easy for me to understand it is supposed to be working ( I have also tested it and it works)

    If I don’t notice any conflicts i will definitely make a small donation 🙂 Unless I buy SSL! Coz you saved me $50 box 🙂 Many thanks!

    To be honest I could set up htaccess ect! (as per wordpress codex, and it would look cleaner but not provide more real security as far as I understand as I am the admin ; this is set up only for admin, and I have set it up myself), But as I don’t have root access to set up a self signed SSl. your plugin really rules and helped me! I don’t mind to have an admin URL that is my shared & Free certificate URL (http://xxx.hostageprovide.com/) , no normal user will be aware about it! (Unless I missed something else, please let me know) Thank you so much!

    *for generic users information, my hosting is servage, I chose it a few years back as it was cheap. I lost root access but it served the purpose for a few cheap clients. They shared ssl definitely seems to work with your wonderful plugin. otherwise for consumers interest! I have had a few down time with servage, and my sites hacked with old wordpress versions. But no major problems over the last three years! But yes I have increased the basic wordpress security plugins, directory access and password! Check google for the latest solutions!

    Thank you plugin maker! You deserve a few bucks from anyone using your plugin! If you want a tattoo design I’ll do it for free! (Japanese style only).

    Plugin Author Mike Ems

    @mvied

    This is new as of 3.2. It will be noted in the FAQ and most likely on the Settings page itself.

    The functionality is completely intentional. Many users wish to use admin functionality on the front-end, so when using Shared SSL and Force SSL Administration, links to the front-end are secured unless Force SSL Exclusively is on. This is done this way under the hood so that I don’t have to add more options. There are enough and I don’t want to add more or change them.

    I assure you, the URL’s you see in the admin panel in no way reflect reality. The only reason you’re seeing them with your SSL is because the plugin is filtering all occurrences of your HTTP URL in page and post links. Again, this is intentional.

    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: WordPress HTTPS (SSL)] Permalink’ is closed to new replies.
Skip to toolbar