Support » Plugin: WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS (SSL)] HTTPS breaks Visual Editor

Viewing 10 replies - 1 through 10 (of 10 total)
  • jupebox

    (@jupebox)

    YES!!

    I have this exact problem. Does anyone have a solution?!

    I went through *all* of my plug-ins, and it’s only this one that disables the visual editor. It’s kind of a bummer because this plug-in rocks.

    Let us know if anyone knows of a solution.

    Joel

    jupebox

    (@jupebox)

    I’ve gone through all the usual stuff … such as changing the theme, disabling all plug-ins, clearing the caches, all that stuff…

    It is definitely this plug-in. Turn it off, and visual editing works immediately.

    Joel

    Uninstalling WordPress HTTPS and re-installing solved this issue on one of the sites on which I was having this problem.

    Also, if your default site address is already https you may want to NOT check the force ssl login and admin boxes in the plugin config.

    After Upgrading to WordPress 3.4.2 the visuell Editor is not working anymore.

    Uninstalling WordPress HTTPS and re-installing it does not help, also installing a development version did not fix it.

    I had to disable the plugin – very pity!

    There will be an upgrade/bugfix in the near future? Thanks in advance for response!

    I am also experiencing this issue after the upgrade to the latest plugin version and latest WP. I am seeing some error lines in my error log that may relate:

    [21-Sep-2012 23:09:31] PHP Warning: parse_url(http:///) [function.parse-url]: Unable to parse URL in /wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Module/Filters.php on line 205
    [21-Sep-2012 23:09:31] PHP Warning: parse_url(http:///) [function.parse-url]: Unable to parse URL in /wp-content/plugins/wordpress-https/lib/WordPressHTTPS.php on line 174
    [21-Sep-2012 23:09:31] PHP Warning: parse_url(http:///) [function.parse-url]: Unable to parse URL in /wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Module/Filters.php on line 235

    I have the same problem. Upgrading from 2.0.4 to 3.1.2 breaks the visual editor. I hope this can be fixed with the next release?

    I should mention I am running the latest version of WP 3.4.2.
    I have turned off all my plugins and turned them on individually to determine that it is this plugin causing the problem.
    By break the visual editor I mean that you can no longer use the visual editor when creating posts/pages.
    restoring to 2.0.4 fixes the visual editor.

    Same problem again. However, I have two versions with the same version of WP and the Plugin. In one version it is working in the other not. Perhaps there is an interference with other plugins (the main difference between these installations).

    I know now which plugin caused the trouble. In my case it is “NextGEN Gallery”. This plugin inserts an icon in the visual editor. I presume any plugin inlcuding links into the visual editor can cause problems because they might not resolve the different URLs e.g. when workikng wiht a shared SSL. So in my case deactivating NextGEN Gallery made the visual editor work again.

    For those of you using an older verison (e.g. 2.0.4) of the https plugin: Is this really working together with the plugins you have also installed for the new version or might this also be a different set up?

    Everything okay now, when using the new version 3.2 of this plugin. Also othter plugins can be used again in the visual editor.

    @schmax thx for the hint! Upgrading to V. 3.2 of this plugin fixes the Problem. Also the other Plugins can be used again. The visuell Editor is working right now.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WordPress HTTPS (SSL)] HTTPS breaks Visual Editor’ is closed to new replies.