Support » Plugins and Hacks » WordPress Flash Uploader » [Plugin: WordPress Flash Uploader] Wrong parameter count for set_time_limit() – Error message on syn

  • Resolved callumw

    (@callumw)


    Low-Pri issue

    Hi
    Using the current release of WFU I’m getting an error reported on syncing some files.

    If I upload through WFU it will rename it to lowercase, generate the pre-defined smaller versions and all is well.

    If I FTP the file up then go to synchronise, the file (still with some uppercase) fails when I try to synchronise it.

    I get the error message with file: 20100527_Thierry_Bearzatto14.jpg

    Warning: Wrong parameter count for set_time_limit() in /......./wp-content/plugins/wordpress-flash-uploader/inc/wfu-sync.php on line 76
    Crunching (1/1): 20100527_thierry_bearzatto14.jpg
    
    Files imported to media library.

    It looks like it does actually work, but it’s an odd error to report when normally it works flawlessly.

    C.

    http://wordpress.org/extend/plugins/wordpress-flash-uploader/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author mdempfle

    (@mdempfle)


    Hi,

    please update to 2.14.1.
    this warning should now not come anymore.

    – Michael

    Awesome 🙂

    Hi,

    I’m not sure of this is related, but I get a lot from these error’s if I click the “sync” tab:


    Notice: unserialize() [function.unserialize]: Error at offset 0 of 11 bytes in /home/olaf/httpdocs/casinogokken.net/webapp/trunk/wp-content/plugins/wordpress-flash-uploader/inc/wfu-sync.php on line 348

    Plugin Author mdempfle

    (@mdempfle)


    This comes when the metadata from the wordpress db is read. Seem there is something corrupt in your database.

    Does the normal media library work?

    – Michael

    Hello Michael,
    yes anthing is fine and the plugin works, but this notices are showing up because I display errors and error reporting is set for development.

    Try to sync on a new site installed on your sandbox, I’m sure you will have these notices too 😉

    Plugin Author mdempfle

    (@mdempfle)


    I can try this weekend – but I get the data from the db there and unserialize them to get the values.

    Plugin Author mdempfle

    (@mdempfle)


    I added some @ that the notice is not shown anymore. Try the new version.

    Hi,
    it would be better to test a variable instead, using @ before a function will eat extra memory 😉

    I will upgrade the plugin tomorrow and let you know if I see the warnings again.

    Thanks!

    Plugin Author mdempfle

    (@mdempfle)


    Test against what? I googled and this error comes when wordpress does not serialize the data correctly to the db. You would have to check your db and fix the invalid entry. An extra \ in the data can cause the problem.
    See http://stackoverflow.com/questions/4149030/php-unserialize-error-at-offset
    So I can use stripslashes but it seems not to happen on any other system yet.

    I’m sorry, I test so many plugins on my sandbox these days and most of the warnings I see are related to non-existing variables. I thought that this was the problem too. I guess the problem in this case, is more related to buggy functions in PHP (no type casting caps.)

    Plugin Author mdempfle

    (@mdempfle)


    The notice for the width is now solved as well.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: WordPress Flash Uploader] Wrong parameter count for set_time_limit() – Error message on syn’ is closed to new replies.