WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » [Plugin: W3 Total Cache] Recently an error occurred while creating the CSS / JS minify cache

[Plugin: W3 Total Cache] Recently an error occurred while creating the CSS / JS minify cache

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Frederick Townes

    @fredericktownes

    If you enable debug mode you can check the minify error log in wp-content/w3tc/min/min.log. Admittedly this feature sometimes gives false positives.

    It sure would be awesome if the email notification mentioned which file had the failure. Just saying “an error occurred” is a little bit microsoft. 😉

    Thanks for the great plugin, by the way!

    PS: I think the log file is wp-content/w3tc/log/minify.log

    PPS: Another awesome feature would be an option to automatically flush the caches whenever any setting changed.

    PPPS: Did I say thanks, again?

    I’m seeing the same, and I agree with the idea that the email could contain a bit more info.

    If it never does though, I’d still use this plugin. It’s the best one I’ve found and still works terrifically. Awesome job!!! Thanks!!!

    Cheers!

    Wayne

    still having it mis-fire a notice. anyone else?

    I started to get this error repeatedly with latest plugin version. It keeps coming up even after I disabled minify for CSS and JS.

    Log entries after enabling debug mode:

    [Sun, 03 Jul 2011 01:19:35 +0000] [/wp-content/w3tc/min/dc2bc0/post.include-footer.4248003223.js] [-] A group configuration for "include-footer" was not set
    [Sun, 03 Jul 2011 06:44:57 +0000] [/wp-content/w3tc/min/dc2bc0/default.include.61659561.css] [-] A group configuration for "include" was not set

    Thanks for the info about the log files – hopefully I can stop my hourly emails!

    Frederick – you should add the location of the log files to the FAQ, as I imagine other users didn’t know they existed.

    I’m receiving a similar error message. My CSS and JS are not being minified.

    Debug mode outputs these log entries:

    [Tue, 05 Jul 2011 02:49:15 +0000] [/wp-content/w3tc/min/72b8dd/default.include-nb.132243207.js] [http://loveandtrash.com/] A group configuration for "include-nb" was not set
    [Tue, 05 Jul 2011 02:49:16 +0000] [/wp-content/w3tc/min/72b8dd/default.include-footer.1418282203.js] [http://loveandtrash.com/] A group configuration for "include-footer" was not set
    [Tue, 05 Jul 2011 02:49:16 +0000] [/wp-content/w3tc/min/72b8dd/default.include-footer-nb.1471229315.js] [http://loveandtrash.com/] A group configuration for "include-footer-nb" was not set
    [Wed, 06 Jul 2011 07:48:21 +0000] [/wp-content/w3tc/min/75c32d/default.include-nb.3650049168.js] [-] A group configuration for "include-nb" was not set

    I too am getting the error, many more times than the log file shows. There’s nothing in the debug content at the bottom of the .html. However I’m getting many more notifications than errors showing in the log. And all of my errors are “Get[‘f’] param invalid: “”. I’m running 3.1.5 (or whatever is right before 3.2).

    [Fri, 01 Jul 2011 01:41:41 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/professional-intimacy-secret-sustainable-leaders/] GET[‘f’] param invalid: “”
    [Fri, 01 Jul 2011 01:42:57 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/the-art-of-disruption/] GET[‘f’] param invalid: “”
    [Fri, 01 Jul 2011 01:46:01 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/the-art-of-disruption/] GET[‘f’] param invalid: “”
    [Wed, 06 Jul 2011 22:07:02 +0000] [/wp-content/w3tc/min/index.php?file=a27498db.a25d8e.js] [http://leadchangegroup.com/blog/] GET[‘f’] param invalid: “”
    [Wed, 06 Jul 2011 22:07:27 +0000] [/wp-content/w3tc/min/index.php?file=a27498db.a25d8e.js] [http://leadchangegroup.com/author/heatherecoleman/] GET[‘f’] param invalid: “”
    [Wed, 06 Jul 2011 22:07:30 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/receiving-input-from-dilbert/] GET[‘f’] param invalid: “”
    [Wed, 06 Jul 2011 22:07:37 +0000] [/wp-content/w3tc/min/index.php?file=12aea2cc.8fe080.css] [http://leadchangegroup.com/receiving-input-from-dilbert/] GET[‘f’] param invalid: “”
    [Wed, 06 Jul 2011 22:08:07 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/receiving-input-from-dilbert/] GET[‘f’] param invalid: “”

    I’m having the same problem, but I just got it working and after starting to configure another site in the same installation (WP 3.2 multisite with domain mapping) the js/css minification suddenly broke.

    The error in the log is

    [Thu, 14 Jul 2011 11:35:57 +0000] [/wp-content/w3tc-0x539.se/min/da7a6d62.ec36f0.js] [-] GET[‘f’] param invalid: “”

    Could this be some problem with .htaccess file/files? I know when i started to configure the other site the first message was that the .htaccess file needed to be updated.

    Current .htaccess config file: http://pastebin.com/J8RhtBLG

    Plugin Author Frederick Townes

    @fredericktownes

    Sorry for the trouble. I wonder if anyone having this issue could please submit a bug submission form from the support tab of the plugin if they’re already using the latest version of the plugin?

    @frederick, I just opened a ticket on the issue and linked to this thread too. Thanks!

    Plugin Author Frederick Townes

    @fredericktownes

    Ok.

    I got the same error message today, though nothing has been changed in the W3TC configuration for a few days.

    enabled minify debug and it doesn’t show any errors just lists the replaced css and js files

    (wordpress 3.2.1, twenty eleven theme)

    @frederick I did a bug report when I was investigating this issue. I can’t really find any reference number to it, but in the report I did reference this forum thread.

    Hope it helps, just contact me if you need further help investigating this issue.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Plugin: W3 Total Cache] Recently an error occurred while creating the CSS / JS minify cache’ is closed to new replies.
Skip to toolbar