Support » Plugin: User Avatar » [Plugin: User Avatar

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author oltdev

    (@oltdev)

    Hi baszer,

    Our testing environment was using WP 3.0 + and we’ve tested this plugin on Firefox, Safari, IE 7+ and know it works for other standard browsers as well. Please make sure that both your WordPress and Internet Browser are working. With the information you have provided it is difficult for me to figure out if there is a problem with the plugin. Also, please grab the latest version and replace the current version of User Avatar on your host. Try to re-activate the plugin and see if that helps out.

    Please also remember that this plugin is made directly for People Lists (http://wordpress.org/extend/plugins/people-lists/) to make it easier for users to upload their photos…something that should be in the core! =]

    Hope this helps,
    ctltdev(former oltdev)

    Hi,

    I’m having the same problem as baszer. I can choose a picture on my computer, I can press the upload button, I can crop the image, but after that in the Here’s your new picture… dialog, the old picture stays there.
    I installed the latest version and tried in Firefox 3.6.8, IE 8.
    I also tried setting permissions to 777 to your plugin’s directory.
    Any ideas?

    Thanks
    Chantal

    Plugin Author oltdev

    (@oltdev)

    Hey cperugino,

    We have set the plugin’s upload directory to 777 permission, so that shouldn’t be an issue…

    if( !file_exists(WP_CONTENT_DIR."/uploads/avatars/") )
    	mkdir(WP_CONTENT_DIR."/uploads/avatars/", 0777 ,true);

    Check to make sure there’s a folder inside your ‘wp-content’ that is called ‘uploads’, which has directory ‘avatars’ and then creates a folder named with uid storing the two sizes of images used.

    Basically check to make sure the URL paths are leading to the right places with your install of WordPress. The program is working fine for me and many other users, so it’s either your permissions or directory structure that may be causing problems.

    Please post back here if you figure out what it is!

    Sorry I can’t be of more help and I will try to find some time to look into it.

    Good luck,
    ctltdev

    Hi! Thanks for the detailed info. I seem to have a problem on the server side. The uploads directory is 777 but not the avatar under it. It refuses to stay at 777. I contacted support to see if they can set it at 777.

    Thanks!

    I got the same issue and the message “Sorry, No file available”
    i’m running in localhost and yes i have a uploads folder inside wp-content folder…

    Plugin Contributor sgagan

    (@sgagan)

    Hi a.luiz.n,

    Your issue is a bit different than the previous posters, but similar in a sense. The code behind your error is:

    if( !file_exists($_POST['attachment_file']) ) {
    		echo "<div class='error'><p>Sorry, No file available</p></div>";

    and..

    <input type="hidden" name="attachment_file" id="attachment_file" value="<?php echo esc_url($file); ?>" />

    For some reason, your file from your disk is not getting read and therefore this error is spit out later in the code because it didn’t POST the image URL on your disk earlier. More than likely, this is a permission error, similar to the previous posters and I would suggest that you set the folder where your image is stored to 777 making them accessible for the plugin to use.

    Hope this helps!

    Also, TO ALL POSTERS HERE, I will be releasing a new updated version of user-avatar…possibly today! I have gotten lots of feedback and hope that you guys like the new functionality!

    Cheers,
    Gagan.

    Hi sgagan!

    I’ve upgraded from user avatar v0.5 to v1.5.
    It did not work for me until I’ve changed:

    line 486 in user-avatar.php
    from
    $avatar_folder_dir = USER_AVATAR_UPLOAD_PATH."{$user}/";
    to
    $avatar_folder_dir = USER_AVATAR_UPLOAD_PATH."{$id}/";

    Sorry, the modified line number is: 483

    Installed the plugin, had no problems uploading my avatar, but when a comment is posted to my blog, I get the following:

    Catchable fatal error: Object of class stdClass could not be converted to string in /home/footb760/public_html/wp-content/plugins/user-avatar/user-avatar.php on line 483

    Along with at notice, the post can no longer be commented to, at least in my eyes. here is a link:

    http://footballingeneralonline.com/2010/08/22/welcome-to-fig-my-first-post-as-this-community-goes-live/#comment-3

    Let me know how to fiox this, as my members are anxious to upload their own avatars/profile pics.

    Plugin Contributor sgagan

    (@sgagan)

    Thanks so much ambro23… I was in a rush to push the changes because it was my last full day at work and I overlooked changing that back in my frantic day! I will push the change to this SVN on Thursday and will relay your message to other users.

    Scott try ambro23’s fix, otherwise, I will update on Thursday.

    Sorry for any inconvenience,

    Gagan.

    hi sgagan,

    i just tried your update, but i still have the same problem. 🙁

    (everything goes well, but after the cropping it says:
    Here’s your new profile picture…
    but then no picture is showed)

    the permissions are set right but i dont know what to do next.

    hope you have the solution

    with regards,
    bas

    baszer and cperugino: same Problem here!
    after upload and crop, no Picture, only a white left/right stripe.

    have found the Problem, but i am to lame to fix it in the .php code from sgagan, hope the Author have time for us to make us happy.

    The Problem are the Directory- and File Permissions of the uploads,
    the Plugin not use:

    define( ‘FS_CHMOD_DIR’, 0755 );
    define( ‘FS_CHMOD_FILE’, 0644 );

    from wp-config.php and write the Directory and Files with default FTP Permissions from the Server, my server writes by default the directory with 2750 and the files with 640 Permissions, and that ist not readable for the Plugin after upload.

    for testing: upload your Avatar and then go to the ftp server and set the directorys under uploads to 755 and all the files under uploads to 644, then this great Plugin works fine, but this way are a lame way, the Author “must” fix it … please!!

    hi all, i have got the solution! (for my problem)

    maybe its helpfull to somebody else.

    First i did not want avatars at all, so i turned the checkbox “do not show avatars” on. I totally forgot, and then i installed your avatar-plugin.

    So people, turn it on!! 🙂

    thank you for your reply.

    Bas

    @affenkind
    Thanks for this fix. I had to change the directory and all the files to 755. I suspect this may be a security loop hole of some sort but I am not an expert. I hope my site is safe. BTW, there is a director under “Avatars” named “2”. I have this working with:

    Theme my Login
    Theme my Profile
    Gravatar for WP
    People lists
    User Avatar (duh)

    Mike

    Update to post: I now have the problem that new users (default Subscribers) don’t seem to have permission to upload a picture. They get redirected to their profile page. Any hints for a hack?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: User Avatar’ is closed to new replies.