Support » Plugins and Hacks » [Resolved] [Plugin: UpdraftPlus] safe_mode is off

[Resolved] [Plugin: UpdraftPlus] safe_mode is off

  • hi,
    i am receiving this error when attempting to do a restore of a backup:

    DB could not be restored because safe_mode is active on your server. You will need to manually restore the file via phpMyAdmin or another method.

    phpinfo() shows that safe_mode is indeed turned “off”, so im at a loss at the moment.

    any ideas on what might be wrong?


Viewing 3 replies - 1 through 3 (of 3 total)
  • i just set up a new, vanilla install of WP on a different web host and have run into the same exact issue. on this new server i have also made sure safe_mode is set to “Off” before install and use of the plugin. backups work fine but restore process fails at the DB restoration function.

    Plugin Author David Anderson



    Sorry for the slow reply – I didn’t realise that this forum didn’t email me automatically if something was posted here…

    If you look in the source code, you can see that that error message is triggered by this conditional:

    if(ini_get(‘safe_mode’)) {

    That’s it… so somehow ini_get(‘safe_mode’) is returning ‘true’ on your server. Can you find out why?

    Plugin Author David Anderson


    Ah, seems from here – http://wordpress.org/support/topic/plugin-wp-super-cache-warning-php-safe-mode-enabled-but-safe-mode-is-off – that your web host has an illegal value in the php.ini. I’ll release a new version to work around that.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: UpdraftPlus] safe_mode is off’ is closed to new replies.