WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Tweetable] Wizard Issue

[Plugin: Tweetable] Wizard Issue

  • I follow the OAuth wizard and in the last step when you click on “Sign in with Twitter”, the link that is displayed is : https://twitter.com/oauth/authorize?oauth_token=

    Result, i get this message from twitter :

    Woah there!
    This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake.

    Please help ?

Viewing 5 replies - 1 through 5 (of 5 total)
  • This generally means that you made a mistake during one of the prior steps, most commonly copying one of the Twitter keys wrong.

    If you go back, there should be a link to restart the installer and try again.

    This is what I have from my PHP error log :

    [09-Jun-2009 13:18:56] PHP Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement—construct]: Entity: line 1: parser error : Start tag expected, ‘<‘ not found in /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/mh_twitter_class.php on line 48
    [09-Jun-2009 13:18:56] PHP Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement—construct]: 302 in /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/mh_twitter_class.php on line 48
    [09-Jun-2009 13:18:56] PHP Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement—construct]: ^ in /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/mh_twitter_class.php on line 48
    [09-Jun-2009 13:18:56] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘String could not be parsed as XML’ in /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/mh_twitter_class.php:48
    Stack trace:
    #0 /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/mh_twitter_class.php(48): SimpleXMLElement->__construct(‘302’)
    #1 /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/tweetable.php(341): Twitter_API->latest_tweet(false, false, false)
    #2 /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/admin_menus.php(137): tweetable_fetch_latest_tweet(Array)
    #3 [internal function]: tweetable_write_twittermenu(”)
    #4 /home/ntux/public_html/www.abesh.net/blog/wp-includes/plugin.php(339): call_user_func_array(‘tweetable_write…’, Array)
    #5 /home/ntux/public_html/www.abesh.net/blog/wp-admin/admin.php(79): do_action(‘toplevel_page_t…’)
    #6 {main}
    thrown in /home/ntux/public_html/www.abesh.net/blog/wp-content/plugins/tweetable/mh_twitter_class.php on line 48

    It’s an XML parse error, which means that Tweetable didn’t get a response from Twitter that was parseable as XML, such as a simple error message. Generally this is a result of an authentication issue, though there’s always a possibility that it’s something else.

    If you go to Twitter.com, log in, and click the Settings link, is there a “Connections” tab with your application listed under it?

    I have the same problem…

    No applications have been approved to use your account.

    I have the same problem…

    No applications have been approved to use your account.

    Make sure that

    1. You entered the consumer keys properly.
    2. You have cURL installed on your server.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Tweetable] Wizard Issue’ is closed to new replies.