WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Tippy] Special caracters doesn’t work

[Plugin: Tippy] Special caracters doesn’t work

  • Hi, you see the problem here (at the end, “llegat”):

    The WP config in Catalan language, and HTML header, too. But the tooltips doesn’t work great.

    An idea?

    This is other problem for me, Tippy doesn’t work inside html labels. For example:

    <ul style="text-align: justify;">
    	<li> Fer un [tippy title="llegat" header="off"]Consisteix en destinar un bé patrimonial específic o una suma de diners, o una renda a favor de la Fundació.[/tippy]</li>
    </ul>

    But I want congratulate to Columcille for your exclusive tooltip plugin for WP. I am sorry for my bad English.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • At some point I hope to fiddle with this. Have not had time lately, but I’d like to add special character support.

    Hi!

    I had the similar problem.

    I do a change in tippy.php (line 200)
    from

    $tippyString = '<a>htmlentities($tippyNewText) .'\', \''. $tippyHeader .'\', \''. $tippyHref .'\');" onmouseout="domTip_clearTip(\'false\')">'. $tippyTitle .'</a>';

    to
    $tippyString = '<a>htmlspecialchars($tippyNewText) .'\', \''. $tippyHeader .'\', \''. $tippyHref .'\');" onmouseout="domTip_clearTip(\'false\')">'. $tippyTitle .'</a>';

    with it the plugin work well until now =)

    I hope help you!
    sorry my bad english too ^^

    sorry, I don’t know how edit my strange post… the wp hidden the url codes…

    from
    htmlentities($tippyNewText) …

    to
    htmlspecialchars($tippyNewText)…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Tippy] Special caracters doesn’t work’ is closed to new replies.
Skip to toolbar