WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Theme Switch and Preview] cleaning deprecated functions & stuff

[Plugin: Theme Switch and Preview] cleaning deprecated functions & stuff

  • Here are a couple of fixes you might want to include in the next release to avoid throwing “deprecated” notices from your plugin.

    widget.php line 8
    Error: Use wp_register_sidebar_widget() instead. Deprecated in version 2.8.
    – replace register_sidebar_widget with wp_register_sidebar_widget

    inc/admin.php line 7
    Error: Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. Deprecated in version 2.0.
    – replace the 10 constant with ‘manage_options’

    regards.

    http://wordpress.org/extend/plugins/nkthemeswitch/

  • The topic ‘[Plugin: Theme Switch and Preview] cleaning deprecated functions & stuff’ is closed to new replies.