Support » Plugin: Word Stats » Plugin Stuck

  • Hello, so I activated this plugin on two of my blogs and on the larger one of the two, the plugin is stuck and not doing its thing to generate stats.

    I tried to enable/disable plugin and I made sure that wp-cron isn’t disabled, so I’m kind of at a loss why its not working.

    would it being on a blog site in a pw-protected folder affect it?

    http://wordpress.org/extend/plugins/word-stats/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Fran Ontanaya

    (@fran-ontanaya)

    Probably not, but I’ll think about it. After activating it, does it display the yellow message that says, “Word stats collection is scheduled (x posts left). Stats will be available in a little while”?

    The simplest reason for it failing would be that the script is timing out before it finishes its task of processing even a single post. Do you have very large posts, or is the blog hosted in a slow server?

    I’m very interested in your issue, since it shows only in one of the blogs, so I’d like to know any differences between both you can think of.

    It’s not a huge blog, some of the posts are long but not *long long* and it does say “Word stats collection is scheduled (1044 posts left). Stats will be available in a little while”

    might I make a suggestion, giving the user the ability to manually run the script?

    ok, so after running the wp-cron.php several times, individually, it worked. then went back to scheduled after i changed word count to “5000”

    (I don’t know what the highest count is on one post/page, but I wanted to include everything)

    Plugin Author Fran Ontanaya

    (@fran-ontanaya)

    Until we find the cause, an option could be to disable wp-cron running on page loads and instead use a real cron job to trigger wp-cron every few minutes:

    How to Replace WordPress Cron With A Real Cron Job

    I’ll add manual running to my to-do list.

    another suggestion that the blog owner (of the blog that it did work on) suggested adding a “No Min/Max” word limit option for the writers out there hehe

    Plugin Author Fran Ontanaya

    (@fran-ontanaya)

    It can be changed in the settings page, although someday I’d like to have more advanced settings so people can say, for example, status post formats should have 300 words max, but standard post formats can have any length, etc.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugin Stuck’ is closed to new replies.