WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Simple Mail Address Encoder] Fix for version 1.5.1 in WP 3.3.2

[Resolved] [Plugin: Simple Mail Address Encoder] Fix for version 1.5.1 in WP 3.3.2

  • Simple Email Address Encoder currently enqueues scripts incorrectly which results in an error in WP 3.3.2 if debug mode is true. Here’s a quick fix for it.

    1) Remove wp_enqeue_script call from constructor in simple-mail-address-encoder.php

    2) Add following code to the end of the file:

    if (!function_exists('init_smae_scripts')) :
    	function init_smae_scripts()
    	{
    		// Place the encoding js script in the footer section of the website
    		wp_enqueue_script('smae', plugins_url('', __File__).'/smae.js', false, '1.0', true);
    	}
    endif; // end init_smae_scripts
    add_action('wp_enqueue_scripts','init_smae_scripts');

    http://wordpress.org/extend/plugins/simple-mail-address-encoder/

Viewing 1 replies (of 1 total)
  • Plugin Author Bannerweb GmbH

    @bannerweb

    Hello teeli

    Thanks for your feedback!

    I’ve just changed the script handling within version 1.5.2 of the Plugin.

    Best regards
    Tobias

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] [Plugin: Simple Mail Address Encoder] Fix for version 1.5.1 in WP 3.3.2’ is closed to new replies.